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Labs for InRoads XM  

This document has been prepared for the Colorado Department of Transportation by:   

And the following Sub-consultants:

Copyright

Copyright © 2009 Colorado Department of Transportation. All Rights Reserved

Many of the designations used by manufacturers and sellers to distinguish their products are claimed as 
trademarks. MicroStation and InRoads are trademarks of Bentley Systems Incorporated. Where other 
designations appear in this book, and the authors were aware of a trademark claim, the designations have been 
capitalized.

The Colorado Department of Transportation (CDOT) has accepted this document.  By accepting this 
document, CDOT assumes ownership and all responsibilities associated with this document.  This information 
is subject to change without notice

Disclaimer

Notice of Disclaimer: CDOT provides documents on an “as is” basis.  All warranties and representations of 
any kind with regard to said documents are disclaimed, including the implied warranties of merchantability and 
fitness for a particular use.  Under no circumstances will CDOT, or any of its officers or employees be liable 
for any consequential, incidental, special or exemplary damages even if appraised of the likelihood of such 
damages occurring.  CDOT does not warrant the documents against deficiencies of any kind.  The use of any of 
these documents for work which is under contract with CDOT, does not relieve the contractor from any 
obligation assumed by the contract, or from complete and proper fulfillment of the terms of the contract, nor 
does it entitle the contractor to compensation for damages or loss which could be attributed to such use.

Notice

This manual may be freely copied or distributed for the purpose of providing the Colorado Department of 
Transportation and Colorado customers a consistent guide to using the Bentley suite of products to meet 
CDOT's design and drafting standards.

Software Versions

The software products referred to in this publication are furnished under a license and may only be used in 
accordance with the terms of such license. This document intended for use with the following software 
versions: 

MicroStation® version 08.09.04.88
InRoads® version 08.09.02.16
0209 – Version 04.00 CDOT Configuration

Colorado Department of Transportation
Project Development Branch
CDOT CADD Department
4201 East Arkansas Ave., Rm 290
Denver, CO 80222
www.dot.state.co.us

Bohannan Huston, Inc.
Meridian One
9785 Maroon Circle
Suite 140 
Englewood, CO  80112-5919
www.bhinc.com

Cad Productivity Incorporated
PO Box 281195
Nashville, TN 37228
www.cadprodinc.com

The Envision Group
8517 Excelsior Drive
Suite 205
Madison, WI 53717
www.envisioncad.com



Page 4 Colorado Department of Transportation

 Labs for InRoads XM

Document Conventions

There are several conventions that are used throughout this document to indicate actions to be taken or to 
highlight important information.  The conventions are as follows:

Item
 

Meaning

View Perimeter a command name or a file that you are to select

Tools > Options a command path that you are to select – usually from the pull-down 
menus

Document Name the name of a document that is not hyperlinked

Emphasis style used when referring to important word or phrases

Hyperlink style used when you have a direct link to another document on the web

Key in entering data with the keyboard

Quote style used to indicate an external source quotation

Note: text information about a command or process that you should pay 
particular attention to

1. Numbered Steps actions that you are to perform as part of the lab activities

<D> or Data press the data button on the mouse

<R> or Reset press the reset button on the mouse

<T> or Tentative press the tentative button on the mouse
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Chapter Objectives:

After completing this exercise you will know how to:

 Start MicroStation

 Open a MicroStation design file

 Use the MicroStation mouse buttons

 Navigate the MicroStation interface

 Use the View Control commands

 Assign view controls to the mouse wheel

 Float and dock toolbars

 Show and hide tools on toolbars

 Access the MicroStation Key-in box

Lab 1.1 - Starting MicroStation

To start MicroStation:

1. Select Start >All Programs > Bentley > MicroStation V8 XM > MicroStation V8 XM Edi-
tion

or

Double-click on the MicroStation V8 XM Edition icon located on your desktop.

MicroStation will start and the MicroStation Manager dialog box will appear on your 
screen.
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Lab 1.2 - The MicroStation Manager Dialog Box

The MicroStation Manager is your file management interface in MicroStation. It allows you to create, 
rename, delete, and open files as well as set workspace parameters. Within MicroStation Manager the user will 
set three important components: User, Project, and Interface. Setting these components allow you to more 
easily access the project directory structure and customize the MicroStation interface.

Note: Do not press <Enter> after you key data in a dialog box unless you are ready to apply 
the settings.  Use the <Tab> key or your mouse cursor to move from one field to the 
next to choose or enter your setup options before you Apply or OK the command.

Opening files

1. In the lower right-hand portion on the dialog box set the three components as shown below

♦ User: CDOT User
♦ Project: 12345
♦ Interface: CDOT

Note: The Project option automatically sets the directory to C:\Projects\12345. You’ll 
lean more about the project configuration file (PCF) in chapter 4.

2. In the MicroStation Manager, navigate to \Design\Drawings\Reference_Files folder.

3. Highlight 12345DES_Model.dgn as the design file to open.

4. A thumbnail preview of the file is shown.

5. Select OK to open the design file.
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6. This is a design model file of CDOT project SH 86, which will serve as the example project 
for this class as well as other CDOT training classes.

Note: The CDOT Menu opens automatically. You’ll use this menu later. For now, 
minimize or close the CDOT menu.

Lab 1.3 - Working with the Mouse

While in MicroStation, your mouse operations include:

<D> Data (usually the left button) for selecting tools, highlighting fields, moving dialog boxes, 
confirming actions, etc.

<R> Reset (usually the right button) for terminating commands, rejecting actions, etc.

<T> Tentative (usually the middle button or scroll wheel) for snapping to existing elements at 
exact locations.

Lab 1.4 - Access Pull-Down Menus

Use pull-down menus to select settings and non-drawing commands from the application window.  You can 
either post a menu (display it until you select a function from the menu) or open the menu and select a 
command all in one step.

Post a pull-down menu from the command window

1. Point your cursor to File in the application window and select it by clicking the data point 
once <D>.



Page 16 Colorado Department of Transportation

LAB 1 - Getting Started in MicroStation Labs for MicroStation XM

♦ The pull-down menu appears.

♦ Menu names followed by ... indicate a dialog box will open when you select the item.

♦ Names with an arrow to the right indicate there is a sub-menu associated with the item.

♦ You can also use the keyboard to select a command from a menu.

♦ The bottom portion of the file menu will display a file history allowing the user to open 
previously opened files more easily.

2. Use the up and down arrow keys on your keyboard to move up and down an item list or 
move your cursor.

♦ Text to the right of an item indicates the hot key or shortcut to use to activate the 
command (e.g., Ctrl+N means to hold down the Ctrl key and type N).

♦ Underlined letters indicate a shortcut key to choose an item from a menu.
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3. Move your cursor to Element to show the element pull-down menu. 

Lab 1.5 - Open a Settings Box

1. Select Settings > Locks  > Toggles to open the Locks settings box.

Note: A settings box, like the Locks box, does not have any command buttons (OK, 
Close, etc.).  Settings boxes can be left open while working in MicroStation.
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2. Close the Locks settings box by selecting the X in the upper right hand corner.

Lab 1.6 - Control Views

Turn on additional views

1. From the View Toggles box (lower left of the screen), toggle on
views 2, 3 and 4.  <D>.

Note: By default, views 1-4 open in screen 1, views 5-8 open in screen 2. To move a view 
to a different screen, select the “M” control menu and choose Change Screen.
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2. Select Window > Tile to arrange the views.
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Fit View 1

1. From the View Control toolbar in View 1, select Fit View.

All of the plan view graphics appear in the view.
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Rotate all views to top

1. From the View Control toolbar in View 2 select Rotate View.

2. In the Rotate View tool settings box, set Method to Top. 

3. <D> in View 2 to change it to a top view (verify the view name is Top).

4. Fit view 2.
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5. Repeat the above steps to rotate views 3 and 4 to a Top view and Fit the views.

Zoom In within a view

1. From the View Control toolbar in View 2, select Zoom In.
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2. Place your cursor (the X cross-hair) in the center of the intersection and place a data point 
<D>.

The view is updated to Zoom In twice as close.  The center of the view is the data point you 
identified.
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3. Continue placing data points until you’ve zoomed in to the intersection as shown.

4. Reset <R> to end the Zoom In command.

Turn off the raster files

The model file has aerial photos attached. These raster images can be turned off while working 
in the file.

1. Select File > Raster Manager.

2. Select both .TIF files using the shift or ctrl key.
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3. From the View toggles, bottom left of the dialog bog, toggle off all Views (1-8).

4. Close the Raster Manager box.

Zoom out in a view

1. From the View Control toolbar in View 2, select Zoom Out.

The view is updated to zoom out twice as far.

2. Again in View 2, <D> in the center of the intersection to zoom out again until you can see 
the entire intersection cross road.

Use the Window Area command

1. From the View Control toolbar in View 3, select Window Area.   

2. <D> above and to the left of the beginning of the project.
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3. <D> again below and to the right of the first point as shown (this will draw a box around 
what you want to show close-up).

The view is updated to show the alignment at the beginning of the project.
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4. While still in the Window Area command, move your cursor over to View 4 and <D> 
above and to the left of the alignment end as shown.

5. <D> again below and to the right of the alignment end.

The view is updated to show the end of the project.
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Your views should look similar to the illustration below.

Fit views

1. From View 2, select Fit View.

All of the graphics in View 2 are displayed in the view. The Fit View command is a handy 
way to see all graphics on levels that are on.
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2. With the Fit command active, <D> in views 3 and 4 to select these views to fit.

Close some views

1. Toggle off views 2, 3 and 4 on the View Toggles box.
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Note: You can also click the X icon in the view’s upper right corner to close it or you can 
double-click on the M icon, the control menu icon, in the upper left corner of a 
view.

Make view one fill the screen

1. Select the Maximize button in the upper right corner of View 1.
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2. Fit View 1.

Lab 1.7 - Mouse Wheel Settings

Note: If you do not have a mouse with a wheel, go to the next section titled Try Out Tool 
Boxes.

Use the wheel on the mouse to Zoom In/Out

1. Position your cursor over the center of the intersection.

2. Roll the wheel up; this zooms in on your graphics.

3. Roll the wheel back; this zooms out.

Note: If you <T> on a location before rolling the wheel MicroStation will zoom in/out 
around that point.

Change the wheel settings

1. Select Workspace > Preferences > Mouse Wheel.
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2. Set the Wheel to Pan Left/Right.

3. Select OK to accept the changes and close the dialog box.

4. Move your mouse wheel back and forth to pan in the view.

Note: You can also Pan by selecting the pan command on the View Control toolbar.  
Specify a “from” and “to” point to move in the view. 

    

You can also Pan by pressing <Shift> on the keyboard and click <D> in the view. Then, 
drag your cursor in the direction you wish to move.

a. Practice panning with the Pan tool.

b. Practice panning using <Shift>+<D>.

Note: After you start panning, you can release the both the <Shift> and the <D> keys. 
<D> again to end the command.
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5. Set your wheel for the view control option you prefer (Workspace > Preferences > 
Mouse Wheel).
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Pan the project site

1. Window in to the beginning of the project as shown.

2. Use panning to review the SH 86 project site. 

♦ Start at the POB (STA 100+00) and pan to the right along SH 86.
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♦ Pan across the intersection (between STA 220+00 and 230+00).
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♦ Continuing panning to the right through the transition from rural 2-lane to urban 2-lane 
with curb and sidewalk (around STA 353+00).
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♦ Stop at the POE.

Lab 1.8 - Try Out Tool Boxes

Pull a tool bar from the main palette

1. Select and hold down the Place SmartLine icon from the CDOT Main tool palette to dis-
play the Linear Elements tool bar.

2. Hold down the data button <D> and drag your cursor to the bottom to the Open as ToolBox.
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3. Select the Place SmartLine command.

The Tool Settings box shows this command’s settings options.

4. Select the Place Line command from the Linear Elements toolbar and notice the changes 
in the Tool Settings box.

The Tool Settings box updates for each tool selected.

5. Close the Linear Elements toolbar by clicking the x in the upper right corner.

Float and Dock Toolbars

 Float the Primary Toolbar

1. Position your cursor over the edge of the Primary Tools toolbar at the top of the application 
window.

2. Hold down the data button and drag the toolbar until it “floats” in the view.
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3. Repeat for the Standard toolbar.

Toggle the Primary Tools toolbox off/on

1. Select Tools > Primary.

The Primary Tools toolbox is turned off.

2. Select Tools > Primary again to toggle it back on.

3. Dock the Primary Tools and Standard toolbars back to the upper right corner of the 
application window by dragging the title bar with the data button.

Note: Any toolbar can be docked on the perimeter (top, bottom, left, or right sides) of 
MicroStation’s application window. 

Show/Hide Tools

1. Open the Linear Elements toolbar as shown above. 
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2. Right-click anywhere on the Linear Elements toolbar.  In the list of tools, toggle off Place 
SmartLine.

The SmartLine tool is removed from the toolbar.

3. Right-click <R> again and turn Place SmartLine back on.

4. Right-click <R> and choose List.

5. Toggle off the last four tools.

6. Choose OK.

The toolbar is updated to show these tools hidden.
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7. Right-click <R> and select Show All.

All tools are now shown on the toolbar.

8. Close the Linear Elements toolbar (click the X in the upper right corner)

Note: Use this procedure to customize any toolbar to show just the tools you want.



Page 42 Colorado Department of Transportation

LAB 1 - Getting Started in MicroStation Labs for MicroStation XM

Lab 1.9 - Using the Key-In Box

Open and dock the key-in box

1. Verify the Key-in box is opened and docked.

Note: If the Key-In box is not open, select Utilities > Key-in to open it. 

2. Float the Key-in box from its docked position.
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3. Expand it by grabbing the bottom of the box and dragging down.

Key-ins can be selected from the list but are typically typed directly into the box.

4. Grab the title bar of the key-in box and drag it to the blank space at the top of the 
application window.

The Key-in box docks beside the other tool bars in the application window.

Note: You can also dock the Key-in box at the bottom of the screen if you prefer.

Lab 1.10 - Save settings 

Save settings in the file so the views will look the same when you next open the design file.

1. Fit View 1.

2. In the Key-in box you just docked, place a data point to set the focus in this box (you will 
get a blinking cursor).

3. Key in File (short for File design), then press <Enter> on the keyboard.

Note: You always press <Enter> or <Tab> after key-ins in the Key-in box.

Keep the Key-in box docked.  It is where you will key in all MicroStation commands.
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Note: To Save Settings, you could also select File > Save Settings or use the short cut 
CTRL-F. Most commands can be accomplished with either key-ins or by selecting 
from the menu or toolbars.

By saving settings, the next time you enter this design file, it will be exactly as you left it.

4. Choose File > Exit to exit MicroStation and your design file.

Note: You can change your MicroStation user preferences to always save setting upon 
exiting the file. Select Workspace > Preferences > Operation and toggle on 
Save Settings on Exit. Just remember that if you’re working in another user’s file, 
you’ll change their setting.
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Chapter Objectives:

After completing this exercise you will know how to:

 Attach the appropriate levels by using the Select Group program

 Use Level Display to turn levels on/off

 Use keyins to turn levels on/off

 Set the active level for placing graphics

 Use shortcuts for turning all levels on/off

 Turn levels off by graphically selecting an element

 Turn different levels on/off in different views

 Customize the Level Display and Level Manager boxes

 Sort levels

 Save a view for later recall

 Access CDOT standard level filters

 Use level filters to manage levels and turn groups of level on/off

Lab 2.1 - Starting MicroStation

1. From your desktop’s Start Menu, choose Start > All Programs > 
_CDOT_CADD_Information > Select Group Environment.

2. In the Select Group Environment box, select xxMulti-Discipline, and then select OK.

Note: This will allow you access to all discipline’s levels.
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3. Start MicroStation and open the design file 12345DES_Model.dgn from the 
c:\Projects\12345\Design\Drawings\Reference_Files folder.

View 1 is a plan view of the entire project that you set up in the last lab.

4. Minimize or Close the CDOT Menu.

5. Open View 5 from the View Toggles toolbar (lower left).

6. Fit View 5.

Note: If you want to move View 5 to the left screen, select the Change Screen option 
from the view’s control menu.
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7. In View 1, Window Area around the intersection as shown. 

Lab 2.2 - Working with levels

Sorting Levels

1. Select Settings > Level > Display (or, from the Primary toolbar select Level Display).

The Level Display box opens.  It is used to turn levels on and off.
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2. In the top left corner on the Level Display box, toggle off all of the Views.

With all views off, there are no levels available to turn on/off (the levels are grayed-out).

3. Turn on View Index 1 and leave all other views off.
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4. <D> on the column heading Name to sort by name, then <D> on Used to bring the used 
levels to the top of the list.

5. Scroll through the list of levels.

The levels which are used (those with graphics placed on them) appear in bold text. All 
other unused levels are from the attached libraries.
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6. <D> on the column heading Number to sort by level number.

Note that levels are grouped by number. For example, all Roadway Design levels are 14000 
series; all Right-of-Way levels are 15000 series, etc.
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7. <D> on the column heading Name to sort the levels alphabetically by name and scroll 
through the level list. (If you toggle the Name column, you will sort A – Z, then Z – A).  
Toggle Name until you sort A – Z.

Note: All MicroStation levels are assigned both names and numbers.
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8. Right-click in any column heading (Name, Number, etc.) and toggle off the column 
Logical.

You can customize the look of the Level Display box by turning on/off information 
columns.

Turn levels on/off using Level Display

1. With the levels now sorted by name, <D> on the column heading Used until all used levels 
are brought to the top of the list. This now sorts all used levels alphabetically.
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Note: You may have to click Used twice to get all used levels to the top.

2. Scroll up to the top of the list to see the used levels.

Note: Sorting by Used is a handy way to quickly find a level that you want to turn on/off.
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3. Window Area around the same intersection location in View 5 as in View 1.

4. In Level Display, toggle off View Index 1 and toggle on View Index 5 and scroll through 
the level list.
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5. <D> on the level ALG_PROPOSED_Hor-Alignment-Text to turn it off. 

Note: Level displays are view dependent – you can have different levels on/off in different 
views.
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6. In View 5, hold down the data button and drag to turn off all ALG levels except the 
ALG_PROPOSED_Hor-Alignment level as shown.
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The intersection text is now off in View 5 but on in View 1.

7. Turn off View Index 5 and turn View Index 1 back on.
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8. Hold down the data button and drag across all DES_ levels to turn them off in View 1.
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Only alignment levels are now on in View 1.
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9. Turn off the levels ALG_PROPOSED_Hor-Alignment-Text and ALG_PROPOSED_Hor-
Alignment-Sta-Major in View 1.
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10. Turn on View Index 5 so that both View Index 1 and 5 are now on.

Some levels are now shown with a medium-gray background. When multiple view indexes 
are on, a medium-gray background means that the level is on in at least one of the views, 
but not in all selected views. A light-gray background means the levels are on in all 
selected views, and a white background means the levels are off in all selected views.
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11. Turn on the levels ALG_PROPOSED_Hor-Alignment-Text and ALG_PROPOSED_Hor-
Alignment-Sta-Major.
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Note that the levels are turned on in both views 1 and 5.

12. Turn off View Index 5.
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13. Close View 5.
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Turn levels on/off By Element

1. The station and alignment text levels are currently on. Right-click anywhere over the level 
names and select Off By Element.

2. <D> on the red alignment curve text as shown.
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The level ALG_PROPOSED_Hor-Alignment-Text is turned off by graphically picking an 
element on that level.
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3. Turn off the Level DRAFT_LC-Center_WT-3.
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4. Right-click again anywhere in the Level Display box and select All Except Element.

5. <D> on the SH 86 (mainline) red-centerline.
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6. Fit View 1.

All elements except the centerlines are turned off in the view.  The Off By Element and All 
Except Element are handy options to turn levels on/off without knowing the level names 
or number.

Note: You can also use the Change Level command, with the Level option set to 
Display Only or Display Off, to accomplish the same task.  

  



Page 70 Colorado Department of Transportation

LAB 2 - Levels Labs for MicroStation XM

  Turn on all of the alignment levels (data point <D> and drag across all ALG levels.
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7. Window in to the intersection as shown.

Save a view

1. <D> in the Key-in box to set the focus.

2. Key in sv=intersect,intersection alignments and press <Enter>.

Note: Always press <Enter> or <Tab> after key-ins.

3. <D> in View 1 to select it as the view to save.



Page 72 Colorado Department of Transportation

LAB 2 - Levels Labs for MicroStation XM

4. Verify you saved the view.  Select Utilities > Saved Views.

Note: The Saved Views dialog box opens and the saved view shows in the list.  The 
Saved Views dialog is used to manage your saved views (create and delete views, 
edit view names and descriptions, and recall saved views).

5. Close the Saved Views dialog box.

You may recall this saved view in upcoming labs.
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Turn all levels on/off

1. Right-click again in Level Display and select All On.

All levels are turned on in View 1.

2. Fit View 1.
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3. Right-click in the level display box and select All Off to turn all levels off in View 1.

Note: You can also turn all levels on or off with the key-ins on=all and of=all.

4. Turn all levels back on in View 1.

5. Window in to the end of the project as shown.

Recall the saved view

1. In the Key-in box, key in vi=intersect.

Don’t forget to <Tab> or <Enter> after key-ins.
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2. <D> in View 1.

The saved view of the alignment and stationing is recalled in View 1.  The appropriate 
levels from the saved view are turned on/off.

3. From the View Control toolbar, select View Previous.

The previous view of the beginning of the project is recalled. Notice that all levels are 
turned back on from this previous view.



Page 76 Colorado Department of Transportation

LAB 2 - Levels Labs for MicroStation XM

4. Select View Next.

This recalls the intersection view again with the design levels turned off.

Use key-ins to turn level on/off

1. Key in on=all, then <Tab> or <Enter>.

2. <D> in View 1 to turn all level back on in this view.

Note: Levels are view-dependent.  When using keyins, you must select the view with a 
data point <D> to tell MicroStation which view to turn levels on or off.

3. Key in of=des*.
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4. <D> in View 1 to select View 1.

All DES_ levels are turned off in view 1. You can use wildcards with keyins to turn a group 
of levels on or off.
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Set the active level

1. In the Level Display box, double-click on the level ALG_PROPOSED_Hor_Alignment to 
set it active.

The background color changes to green.

Note: You can also use the lv= key-in to set the active level.

The active level is also reflected in the Attributes toolbar at the top of the screen.

2. Turn all levels off in View 1.
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All levels are turned off except the alignment centerline because it is the active level. 

Note: The active level is always displayed provided the option Display Active Level in 
All Views is toggled on in Workspace > Preferences > Operation. If this option 
is turned off, you can also turn the active level on/off.
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3. Key in lv=14051, to change the active level to the Toe-of-Fill level.

This level is automatically turned on in the view and now shows with a green background 
in the Level Display box.

4. Close the Level Display box.

Lab 2.3 - Working with the Level Manager

The Level Manager shows all of the level libraries that are attached to your design file, level names, numbers, 
descriptions, etc. The Level Manager also displays each level’s ByLevel symbology – the color, line style and 
weight assigned to that level, which conforms to CDOT’s CADD standards. Additional information such as if 
the level is used, frozen, available for plotting, etc. are also shown in the Level Manager.

1. Open the Level Manager.  Select Settings > Level > Manager or on the Primary toolbar 
select Level Manager.
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2. Sort the Level Manager on Used to bring all the used levels to the top of the list, you may 
need to scroll over to the right to see the column Used.

Level Libraries

Level libraries are master templates of levels. The discipline-specific level libraries (Roadway 
Design, ROW, Alignments, etc.) are attached to your design file via the Select Group 
Environment utility program that you ran before starting MicroStation. The Select Group 
program has two options: Bridge and xxMulti‐Discipline. All groups except Bridge should 
choose xxMulti‐Discipline to attach all level libraries. The Bridge option just attaches level 
libraries needed for the Bridge group. 

When a level is set active and graphics are placed on this level, the level is copied from the 
library file to the active design file.

Used levels that are copied to the design file appear bold in the Level Manager. All unused 
levels are in the library.

1. Scroll through the list of levels.

All levels have a logical level naming convention according to their library (e.g. all 
roadway design levels start with DES, all alignment levels with ALG, topo levels with 
TOPO).

2. Right click in the column headings and toggle Library on.
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The library name is now shown in its own column in Level Manager.

Change the look of the Level Manager box

1. Right-click in any column heading (Name, Number, etc.) and select List.

2. Toggle heading on or off so that Name, Color, Style, Weight, and Used are on and select 
OK.
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The Level Manager box updates to reflect the changes.

3. Close the Level Manager box.

ByLevel Symbology

ByLevel symbology ensures that CDOT CADD standards are met by placing graphics ByLevel 
(the color, line style and weight assigned to that level in the level library).  

Note: When placing graphics using the CDOT Group Menus, the correct level, along 
with it’s ByLevel symbology is automatically set for you.

Analyze an element

1. In the Key in box type vi=intersect, Enter the keyin and then <D> in view 1 to recall the 
alignment saved view.

2. From the Primary toolbar, select Element Information.

3. <D> on the horizontal alignment centerline graphic.
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Element Information shows that the alignment was placed on 
ALG_PROPOSED_Hor_Alignment level and placed with ByLevel Symbology. 

4. Exit out of the Element Information box.

5. Open the Level Manager box.

6. Find the ALG_PROPOSED_Hor_Alignment level and note the ByLevel Symbology is set 
up in the Level Manager.
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Review Pop-up information

1. Hold your cursor over the centerline of SH 86 (the mainline alignment).

MicroStation’s “pop-up” information tells you the type of graphic (line) and the level on 
which it is placed (ALG_PROPOSED_Hor_Alignment.) Pop-up information is a quick way 
to determine what level graphics are on.

Level Filters

Level Filters are groups of levels created in the Level Manager by filtering on virtually any 
level criteria (name, number, color, etc.) and then naming the filter. These level groups can then 
be turned on/off using the filter.

Review the filters

1. In the left pane of the Level Manager box, click on Filters.

2. Click on the column name Filter to sort alphabetically by filter name.
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3. Turn on the Number column.

There are several standard CDOT filters, which are based on name and number.  The 
CDOT standard level naming and numbering convention enables the efficient use of level 
filters.

Note: Level filters are stored in level libraries (note the library name in brackets beside 
the filter).

4. In the left pane of the Level Manager, Click the + symbol next to the Filters to expand the 
list.
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5. Click the + symbol next to the Roadway Design to expand this list.

6. Click on Roadway to review the levels that make up this filter (all design levels with 
Roadway in the name).

Note that this filter contains both used levels in the active file and unused levels in the 
library.
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7. Click on Guardrail to review all design levels with Guardrail in the name.

Note: This filter does not have any used levels in the active design file. All levels are 
from the library.

8. Right-click in any column heading and turn on the Number column. 

9. Click on the upper level Roadway Design filter and review levels.

Note that this filter is not filtered on name, but instead contains all levels in the Roadway 
Design level number range (14000 – 14999).  This includes all “children” filter levels like 
Guardrail and Roadway.

Use level filters to turn levels on/off

The level filters are stored in the level libraries, accessed via the Level Manager. However, to 
actually use the filters, you need to use Level Display.

1. Close the Level Manager.
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2. Open the Level Display box from the Primary toolbar.

3. Set the active level to Default by double-clicking it in the Level Display box.

4. Turn off all levels.

5. Change the Show option from Levels to Filters. 

6. Sort the Level filters alphabetically in ascending order.
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7. Toggle on the Alignments filter.
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Only the alignment levels (centerline and stationing levels) are turned on. Choosing the 
filter turns on all levels in the filter.

Note: If you toggle the filter off, it turns all levels on by default. However, selecting the 
filter again resets the filter and turns on only the filter levels.

Use level filters to select a group of levels

1. With the Alignments filter selected, change the Show option back to Levels.
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2. Change the List Filter from (none) to Alignments > Proposed.

The list of hundreds of levels is filtered down to only a few (the levels contained in the 
Proposed Alignments filter).
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3. Turn off the ALG_Proposed_Hor-Alignment-Text and ALG_Proposed_Hor-Cardinals 
levels.

Note: Use Level Filters to improve your MicroStation efficiency when searching for 
levels. Setting the List Filter is an efficient way to work with levels. Instead of 
scrolling through hundreds of levels to find a level to turn on, off or set active, the 
filter breaks the levels down into a logical and manageable group. 
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4. Set the List Filter back to (none) to show all levels in the Level Display list.

5. Close the Level Display box.

6. Fit View 1.

7. Save your settings (File > Save Settings).

8. Exit MicroStation.
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Chapter Objectives:

After completing this exercise you will know how to:

 Check the elevation of an element

 Rotate a view using the rv= keyin

 Rotate a view using the 3-point method

 Rotate a view by element

 Rotate to a standard view (Top, Front, etc.)

 Check and set the Active Depth

 Check and set the Display Depth

Lab 3.1 - Starting MicroStation

1. Start MicroStation and open the design file 12345DES_Model.dgnfrom the C:\Proj-
ects\12345\ Design\Drawings\Reference_Files folder.

You will use this CDOT project, which has proposed graphics placed at the correct 
elevations, to practice with the concept of 3D view controls. 

2. Look in the top title bar of the MicroStation window and note that this is a 3D file.
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3. Fit View 1

The design file shows only the proposed alignments because only the ALG levels were 
turned on when settings were last saved.

Lab 3.2 - Checking element elevations

You can quickly check the coordinates of any point (including the Z coordinate in a 3D file) by placing a 
tentative point.

1. Key in vi=intersect to recall the alignment saved view.

Note: Always press <Enter> or <Tab> after keyins.
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2. <D> anywhere in View 1 to recall the saved view.

The design file has some graphics, like the horizontal alignment, placed at elevation 0. 
Other graphics, like contours generated by InRoads, are placed at an elevation range of 
approximately 6600 ft.

3. On the Attributes toolbar, set the filter to Alignments-Proposed and then set the active 
level to ALG_PPROPOSED_Hor-Alignment.
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4. Place a Tentative point <T> on the North-South crossroad alignment just south of the 
intersection. 

Note: The Tentative button in the CDOT workspace is set to the middle button on the 
mouse. If you want to change it, select Workspace > Button Assignments.

The tentative point jumps to the closest keypoint on the element. You will see a large cross-
hair at the keypoint.  You’ll learn more about keypoint and other snap modes in other 
chapters.

A tentative point is a temporary location that displays the coordinates for the point in the 
Message Field (bottom of screen).

Note that the centerline alignment graphic in the top view (plan view) has a Z value of 0. 
Therefore it has an elevation of 0.
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5. Open Level Display and set the level Filter to None to show all levels.  Sort by Name and 
then Used levels.  Turn on the levels DES_ROADWAY_Toe-of-Fill and 
DES_ROADWY_Top-of-Cut.  
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6. <T> on one of the cut or fill lines and note its elevation (Z coordinate).

7. <T> on a few other top or toe lines and note the elevations.

The graphics should be placed at a depth of approximately 6620 ft. or within a close range.

8. In Level Display, click on the + symbol next to the file 12345SurveyTopo100Scale.dgn 
to expand the list of reference files. 
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9. Highlight the reference 100Scale2_10,12345SURV_Contour100.dgn and turn on levels 
TOPO_TERRAIN_Contours-Major and TOPO_TERRAIN_Contours-Minor.

Note: The contour file is a reference to the design model file. You’ll learn more about 
references in the Create the Project and Design Model lab.

10. Window in on some of the contours to the right of the intersection so that you can easily 
read the labels.
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11. <T> on some of the major contour graphics and note the elevations.

The major contours are placed at 10 ft. intervals.
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12. <T> on some of the minor contour graphics and note the elevations.

The minor contours are placed at 2 ft. intervals.



Page 104 Colorado Department of Transportation

LAB 3 - 3D View Control Labs for MicroStation XM

13. In Level Display, turn off the existing major and minor contour levels as shown.
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14. In Level Display, highlight the 12345DES_Model.dgn file to work with the master file 
levels again and turn all levels on.

Lab 3.3 -  Rotating a 3D Standard View

1. From the View Control toolbar, select Rotate View.

  

2. In the Tool Settings box, set Method to Front.
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3. Fit View 1.

The view is rotated from Top (plan view) to Front (elevation view). Note that some 
graphics, (like the red horizontal alignments you checked earlier), are displayed at 
elevation 0 below the proposed graphics (edges of oil, cut/fill lines, etc.), which are 
displayed at the correct elevation (6620 ft. range).

Note: Rotating to the Front view is a handy way to visually check your file for erroneous 
information or bad elevations which “spike” down to 0.
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4. Select the Rotate View command again and set the Method to Top.

  

This returns the view to a plan view and its original un-rotated settings.

5. Key in vi=front.
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6. <D> to select the view.

The view is rotated back to an elevation view.  You can use the vi= keyin to rotate to 
standard views (top, front, isometric, etc.) as well as to recall saved views.

7. Key in vi=iso.

8. <D> to select the view.
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9. Fit the view.

10. This gives another 3D perspective of the design file graphics.

11. Select the Rotate View command again and set the Method to Dynamic.

12. <D> near the intersection in the view to identify it for rotation, then move your cursor in a 
counter-clockwise motion.

As you move your cursor the view dynamically rotates.
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13. Zoom in on the intersection and continue experimenting with the Dynamic rotation option 
until you’re comfortable with the tool.

Note: If you <T> on a location (like the intersection center) after selecting the Dynamic 
method, you will rotate about the tentative point.

Lab 3.4 - Check the Active Display Settings

Check the Current Active Depth

1. Rotate the view back to Top.

2. Fit the view.

3. In the MicroStation Key-in box, key in az=$ to check the active depth.

Note: The dollar symbol ($) is used to request current settings. You can also use a 
question mark (?).

MicroStation prompts: Select View.

4. <D> anywhere in View 1 (top view).

Note: Active and Display depths are view dependent (i.e. you set these in each view).  
Therefore, you have to tell MicroStation which view you want to check the Active 
Depth in by data pointing in the view.
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5. Check the Message field.

MicroStation returns the current active depth setting. Yours may be different than shown. 
This means if any graphics are placed in the design file’s top view without giving them an 
elevation, they will go in at this elevation or depth.

Since the depth axis of the top view (plan view in a 3D file) is the Z axis, this means 
graphics will be placed at this elevation.

6. Key in az=0.

7. <D> to select the view.

8. Key in az=$.

9. <D> to select the view.

You have now set the active depth to 0.  Any new graphics placed in the file will be placed 
at an elevation of 0, unless you snap to an element at another elevation.
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Check Current Display Depth Settings

1. Window in around the intersection.

2. Key in dp=$, then press <Enter>.

3. <D> in View 1.

4. Check the Message for the current display depth settings.

The current display depth in the top view is set very large. Yours may vary from that 
shown.  Therefore, you are able to see all the graphics in the top view since they fall in the 
depth (elevation) range.

5. Key in dp=6000,7000.
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6. <D> anywhere in View 1 and look at your graphics.

The graphics placed at this elevation range (shoulder, edge-of-oil, cut/fill lines, etc.) now 
appear in the view.  All of the graphics placed at elevation 0, like the red proposed 
horizontal alignment, stationing and alignment text, are not displayed.

7. Key in dp= –10,100.
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8. <D> anywhere in View 1 and look at your graphics.

Only the elements placed in this elevation range (e.g. the proposed horizontal alignment 
and text placed at 0) appear in the view.  All other graphics are outside of this elevation 
range and are not displayed.

9. Fit View 1.

All of the graphics appear in the view.

10. Key in dp=$.

11. <D> anywhere in View 1 and check the Message field.

The display depth range is automatically expanded after using the Fit command to show all 
of the elements in the view.

Lab 3.5 - Turn On Raster Images

1. Select File > Raster Manager.
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2. Select both raster images using the Shift or CTRL buttons and toggle on View 1 from the 
lower left of the dialog box.

3. Close the Raster Manager box.

4. Fit View 1.

The raster images are now on for a future lab.

5. Select File > Save Settings.

6. This saves all settings changes, including open views, levels turned on/off, active and 
display depth settings, etc.  The next time you enter this design file, it will appear just as 
you left it.

7. Exit MicroStation.
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In this lab, you’ll create a new 12345 project using the Create Project Directory Structure program. 
Then, you’ll create a new Roadway Design model from an auto-populated file (generated by the Create Project 
Directory Structure program) and by creating one from a CDOT 3D seed file. Once created, you’ll reference 
other discipline’s work in order to start the design. 

In subsequent labs, you’ll use a similar process to create other discipline model files (Bridge, Landscape & 
Environmental, Traffic, etc.).

Chapter Objectives:

After completing this exercise you will know how to:

 Create a new project and project configuration file (PCF) using the Create Project 
Directory Structure program.

 Re-assign a project number via the PCF.

 Create a new design model using a CDOT seed file.

 Create a new design model using an auto-populated model file.

 Attach a reference.

 Turn reference displays on/off.

 Turn reference levels on/off.

Lab 4.1 - Create a Sample 99999 project

In this example, you are starting your project before a project number has been assigned. You 
will temporarily assign the project number 99999. Later in this lab, you will learn how to 
change this project number by updating MicroStation’s project configuration file.

1. From the Windows Start Menu, select Start > All Programs > 
_CDOT_CADD_Information > V08.09.xx-XM > Create XM Project Directory 
Structure.

2. Verify that the Project Template location is set to C:\Workspace > Workspace-
CDOT_XM > Project Template.

3. Set Destination to C:\Projects.

4. Key in 99999 for the Project Code.

The project number must be a 5-digit numeric code.

5. Toggle on Create Project Configuration File.

6. Select Apply.
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The project directory structure is created in the C:\Projects folder and the Project 
Configuration File (PCF) file is created.

7. Close the CDOT Project Creation Utility.

8. Use My Computer or Windows Explorer to navigate to the C:\Projects\99999 folder to 
review your project directory structure. Note that several generic CDOT files (e.g. 
99999Des_Model.dgn) have automatically been created.

9. Use My Computer or Windows Explorer to navigate to C:\Workspace > Workspace-
CDOT_XM > Standards-Local > Projects.



Colorado Department of Transportation   Page 119

Labs for MicroStation XM LAB 4 - Creating the Project and Design Model

10. Double-click on the 99999.pcf file to open it in Notepad.

The PCF defines a specific directory that MicroStation defaults to when opening up a DGN 
file or referencing model files. It makes setting paths much easier in MicroStation. 

If your project was installed on a project manager’s machine, you could edit this file to 
specify the location. See the CDOT PCF Management workflow for more information.

11. Close the Notepad file. If prompted to save changes, select No.

12. Close My Computer or Windows Explorer.

You will later edit the 99999 project and update it with an actual project number. For now, 
you will continue working in the example 12345 project.

Lab 4.2 - Select Group Environment

Run the Select Group Environment Utility to determine which CDOT level libraries will 
be attached and available for use.

1. From your desktop’s Start Menu, choose Start > All Programs > 
_CDOT_CADD_Information > 08.09.xx-XM > Select Group Environment. In the 
Select Group Environment box, select xxMulti-Discipline, and then select OK.

Any MicroStation design file that is now opened will have all level libraries (general and 
all disciplines) automatically attached.

Note: You only have to run this program once.  The only time you have to re-run it is if 
you wish to switch groups on the same machine.
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Lab 4.3 - Start MicroStation

1. Start MicroStation by double-clicking the desktop shortcut or by selecting Start > All Pro-
grams > Bentley > MicroStation V8 XM > MicroStation V8 XM Edition.

Set the Workspace components

1. In the lower portion on the dialog box, set: 

♦ User:  CDOT User
This sets user preferences and users customized options like custom toolbars.

♦ Project: 12345

Note: Be sure to re-set this option because it will default to you upper level project 
directory.

This Project component of the workspace should already be set by the PCF file created by 
running the CDOT Project Creation Utility. It sets the proper path for opening, saving and 
attaching files.

♦ Interface: CDOT
This loads custom menus and tools at the organizational level. The CDOT interface will 
load, among other things, the CDOT Groups Menu.

Lab 4.4 - Create a new Design Model File

There are two ways you can create a new file: Using a seed file or from a CDOT auto-
populated model file. You’ll practice both in this session.
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Creating a new design file using a CDOT seed file

1. From the MicroStation Manager dialog box, select the New File icon.

2. In the Seed File section, choose the Browse button.
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3. Highlight the seed file 3D-Seed_CDOT.dgn and choose Open.

Note: The seed file will copy over all of CDOT’s default MicroStation settings when 
creating the new file.

4. Set the Directory to \Design\Working.  

5. Set Save as Type: to MicroStation DGN Files (*.dgn ).

6. Key in the name CU12345DES_Model02.dgn.

7. Select Save to create the file.

The file is created from the seed file and placed in the Working folder. When creating a 
new working model file, you’ll prefix it with your initials (you’ll use CU for CDOT USER 
for this class).

The working folder is for files that you are using for your design process prior to the design 
being finished. Once complete, you will move the files to the Reference_Files folder and 
take the CU off of the file name.
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8. In the MicroStation Manager box, choose Open.

9. The blank file opens with all of the standard settings from the CDOT seed file.

Check settings

1. Select Settings > Design File > Working Units. These are the CDOT standard units 
copied from the seed file.

2. Cancel the dialog box.

3. Choose File > Close to return to the MicroStation Manager.



Page 124 Colorado Department of Transportation

LAB 4 - Creating the Project and Design Model Labs for MicroStation XM

4. From the MicroStation Manager select the file and press the Delete key on your 
keyboard and choose Yes from teh Delete File box to delete the file you just created.

Lab 4.5 - Create a New File by copying an auto-populated model 
file

1. In the MicroStation Manager, navigate to the \Design\Draw-
ings\Reference_Files folder.

2. Select 12345DES_Model##.dgn and choose Open.
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3. After opening the file, select File > Save As, navigate to the \Design\Working folder 
key in the name CU12345DES_Model02.dgn and select Save.

The file is copied to the new name into the working folder. 

Check settings

1. Select Settings > Design File > Working Units. These are the CDOT standard units, 
which are the same as the seed file units.

2. Cancel the dialog box.

Note: The auto-populated file provides the same settings as a seed file. You can create a 
new file either way with the same results. However, by copying a CDOT auto-
populated file, the name is automatically set to the CDOT standard, you only have 
to change the counter.
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Lab 4.6 - Attach the Survey/Topo reference

After creating your initial design model, you can attach other groups’ work that you’ll need to 
start your design. In this case, attach the existing survey and topographic information.

1. Select File > Reference.

Note: You can also choose References from the Primary toolbar.

2. On the References dialog, select Tools > Attach.

3. Your current Directory should be C:\Projects\12345 (obtained from your PCF file).

4. Navagate to \ROW_Survey\Drawings\Reference_Files

5. Select 12345SURV_Topo100.dgn from teh list of files.

6. Set Attachment Method to Interactive and select OK.

The Interactive method allows you to supply additional reference settings in the next dialog 
box. 

7. In the Reference Attachment settings box, key in a Logical Name of Survey/
Topo and set:

♦ Orientation to Coincident World (to align Master file and Reference file global 
origins)
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♦ Scale to 1:1 (to bring in graphics full scale)

♦ Nested Attachments to No Nesting
♦ Display Raster Reference on

♦ Global Linestyle Scale None

8. Select OK.

9. Fit the view.

The Survey/Topo reference is attached to the design model master file. The graphics come 
in at their true coordinates (Coincident-World) and the actual size (1:1 scale).
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10. Window in on the Survey graphics at the beginning of the project.

11. In the Reference dialog, make sure Show Hierarchy is turned on and highlight the 
Survey/Topo reference on the right-side.

12. Toggle the Display option off.

13. Fit the view.

With the reference display turned off, there are no graphics to display, since the design 
model is currently empty.

14. Toggle the Display option back on.

15. Fit the view.

The design file is now ready to placed proposed graphics with survey and topo graphics 
referenced for information purposes.



Colorado Department of Transportation   Page 129

Labs for MicroStation XM LAB 4 - Creating the Project and Design Model

Turn survey levels on/off

1. Window around the intersection near the center of the project.

2. Zoom in as shown.
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3. Hover over one of the barbed wire fence lines.

Basic element information “pops up” at your cursor location. MicroStation tells you that 
the element is on level TOPO_FENCE_Barbed-Wire and located in the Survey/Topo 
reference. 

4. Open Level Display from the Primary toolbar.

5. Highlight the master file CU12345DesignModel02.dgn.

6. Sort on Used levels.

Note: That there are no used levels in the master file since there are no graphics in the 
design model file.

7. Highlight the Survey/Topo reference underneath the master file
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8. Sort on Name, then sort on Used.

Note: That the reference has several used levels.

9. Turn off the level TOPO_FENCE_Barbed-Wire.
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10. Right click in the list of levels and select Off By Element.

11. <D> on one of the green breaklines to turn off the level TOPO_TERRAIN_Break-Lines.
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12. Update the view.

13. Turn other Survey levels on/off as desired.

Note: You have control over all reference levels just like levels in the master file.

14. Turn all Survey levels back on.

15. From the MicroStation Main toolbar, select Delete Element.
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16. <D> on the barbed wire fence.

The command is now not available because the barbed wire fence is in the reference file, 
not the active file. You can not delete or modify reference graphics.

17. In the Reference dialog, turn off Snap for the Survey/Topo reference.

18. Try to tentative snap on some of the Survey graphics.

With Snap turned off, you can’t tentative to the graphics in the reference file.

19. In the Reference dialog, and turn off Locate for the SurveyTopo reference.
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20. On the Main toolbar, choose the Element Selection tool and hold your cursor over some 
of the survey graphics.

 

With Locate off, you can’t located reference elements for information, measuring, 
copying, etc.

21. In the References dialog, turn Snap and Locate back on for the Survey/Topo 
reference.

22. Hold your cursor over some of the reference graphics.

You can now locate the graphics.
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23. <T> on some reference graphics.

You can now snap to the reference graphics for coordinate information.

Note: It’s often helpful to turn Snap off in a reference in dense areas where you don’t 
want to snap to reference graphics. It’s useful to turn Locate off for a reference if 
you’re copying master file graphics and you don’t want to accidentally copy the 
reference graphics.

Live Nesting

1. Window around the intersection as shown.



Colorado Department of Transportation   Page 137

Labs for MicroStation XM LAB 4 - Creating the Project and Design Model

2. In the Reference dialog, change No Nesting to Live Nesting and set the Depth to 1. 
Expand the Hierarchy list to show all nested references.

The Survey fieldbook data files, which are referenced to the Survey/Topo model, are now 
displayed in the file.

3. Review the graphics.

The Nested graphics, including the existing contours are now shown in the file.
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4. On the left side of the Reference dialog, highlight the Survey/Topo reference. On the 
right-hand side of the References box, highlight the Contour (Surface data) nested 
reference and toggle off the Display.

 

The display of just the nested contour graphics is turned off.

5. Turn the Contour reference Display back on.
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6. On the left side of the Reference dialog, highlight the Design Model master file. On 
the right-hand side of the References box, highlight the Survey/Topo reference and 
toggle off the Display.

All graphics in the file are turned off. 

Note: With a nested reference, when you turn off the display of the upper level reference, 
all nested references are turned off too.

7. Turn the Survey/Topo reference display back on.

8. Open the Level Display box and expand the Target Tree list.
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9. Select the Contour nested reference and toggle off the minor contour level.

You have control over all nested reference levels via Level Display.

10. Turn the minor contours back on and Close the Level Display box.

You will work more with nested references and the Copy Attachment options in later labs.
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11. Choose File > Close to return to the MicroStation Manager.

12. From the MicroStation Manager select the file CU12345DES_Model02.dgn and 
press the Delete key on your keyboard and choose Yes from teh Delete File box to delete 
the file.

Note: In this class, you’ll work with the previously created Design Model file 
12345DES_Model.dgn in the Refereence_Files folder.

13. Cancel the MicroStation Manager box.

Lab 4.7 - Update Project 99999

You have now been assigned a project code of 54321 for the previously created 99999 
project. Update the PCF to reflect this change.

1. Using My Computer or Windows Explorer, navigate to the CDOT workspace (C:\Work-
space\Workspace-CDOT_XM\Standards-Local\Projects).
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2. Double-click on 99999.pcf  to open it with Notepad.

3. On the second line under Project Directory, edit it as follows:

MS_DEF=C:/Projects/54321/

 

4. Select File > Save As, name the file 54321.pcf. and select Save.

Note: By updating the MS_DEF path, all reference paths are updated as well.

5. Close the 54321.pcf file in Notepad.
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6. Delete the 99999.pcf file from the C:\Workspace\Workspace-
CDOT_XM\Standards-Local\Projects folder.

7. Using My Computer or Explorer, navigate to the C:\Projects\99999 folder.
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8. Rename the folder C:\Projects\54321.

9. Start MicroStation and select the Project drop-down

Note that 99999 is no longer available and has been replaced by 54321.
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10. Set Project to 54321.

The project directory structure is selected.

Note: All files prefixed with 99999, would need to be renamed with the prefix 54321 on 
the hard drive.

11. Cancel the MicroStation Manager.
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In this lab you will learn how to access the CDOT Menu and become familiar with its different components 
and operation. You will use the CDOT Menu to set standards (level, color, line style, line weight), 
automatically select drawing tools, and then place basic elements (lines, circles, arcs, etc.).

Chapter Objectives:

After completing this exercise you will know how to:

 Access the CDOT Menu

 Access the CDOT Bridge Menu

 Use the CDOT Menu to set element attributes

 Use the CDOT Menu to place basic elements (lines, arcs, circles, shapes, etc.)

 Use the Delete command

 Use the Undo and Redo functions

 Change the element highlight color

Lab 5.1 - Create a Miscellaneous Details file

Create this file to practice placing graphics using the CDOT Menu, as well as to draw a few 
miscellaneous details that later can be placed on a sheet.

1. Start MicroStation from your desktop shortcut or from the Start Menu.

2. From MicroStation Manager, select the New File icon.

3. Verify the Seed File is set to 3D-Seed_CDOT.dgn.

4.  Set the Directory to \Design\Working.

5. Key in a file name CU12345DES_MiscDetails01.dgn.

Note: CU stands for “CDOT User” the initials you’ll use for training purposes.
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6. Select Save.

7. With the CU12345DES_MiscDetails01.dgn file highlighted in the MicroStation 
Manager, select Open to open it.
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Check Seed File Settings

1. Select Settings > Design File... then select Working Units and review the CDOT defaults.

2. Cancel the dialog box.

3. Key in dp=$ to check the display depth.

4. <D> anywhere in the view to select it.

5. Review the CDOT defaults in the message field.

6. Key in az=$ to check the active depth.

7. <D> anywhere in the view to select it.

8. Review the CDOT defaults in the message field.
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Open the CDOT Menu

1. The CDOT Menu opens automatically when MicroStation is started. If it has been closed 
and needs to be re-opened, select the CDOT icon CDOT Main toolbar.

2. The CDOT Menu opens. The CDOT menu is broken up into several main parts, as shown 
below.

3. Selecting Settings allows the user to apply an Active Scale and Active Angle to elements 
being placed.
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4. From the pull-down menus select CDOT Groups > Select All.

5. Select Drafting from the Explorer Window.

6. Review some of the categories and items available for general drafting.
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7. Select Design from the Explorer Window.

8. Review some of the categories and items available for the Roadway Design Group.

9. From the Explorer Window, open other groups of interest (Hydraulics, Traffic, Utilities, 
etc.) and review the available categories and items.
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Lab 5.2 - Place Graphics with the CDOT Menu

Place Lines

1. In the CDOT Menu Explorer select Drafting, then select the Linework category.

2. This category is used for general drafting work that is placed on standard drafting levels.  
The Filters are used to organize the different linework Items. 

3. Set the Filter to WT, for line weight 

4. Select the Item Weight 3.
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The filter determines the appropriate drafting level for the SmartLine.  The Smartline 
command is the default for this menu item.  All other drafting commands should be either 
be picked from the CDOT Main tool bar or entered as a key-in.

5. Data point in View 1 to enter vertices for the SmartLine.

6. <R> when finished.

Note: Always <R> when you are finished drawing an element. The active drawing tool 
(in this case SmartLine) remains active so that you can place another line without 
having to re-select the item from the menu.

7. The seed file settings have line weights turned off to provide a better on screen display. To 
see the line weights, select the view attributes icon from the view tools at the bottom of 
each view window. You may also select Settings > View Attributes from the MicroStation 
pull-down menus. Toggle Line Weights on.
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Note: Selecting the down arrow from the view attributes icon will open the dialog 
box temporarily allowing the user to toggle on line weights without bringing up the 
dialog box permanently. The dialog box will dissapear when the mouse if moved 
away.

8. If you have opened the View Attributes dialog box, close it and return to the CDOT menu.

9. Set the Filter to LC, for linestyle.

10. Select the Item Dashed (Thick).
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11. Place another SmartLine and note the change in line style and the active level on which it is 
placed. 

12. <R> when done.

13. Set the Filter to CO, for Color.

14. Select the Item Plot Orange.
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15. Place another SmartLine and note the change in both line style and color and the active 
level on which it is placed. 

Place Circles

1. In the CDOT Menu, set the Category, Filter and Item to establish whatever level and 
symbology you like.

2. From the CDOT Main tool palette, select the Circle icon.

3. In the Tool Settings box, set Fill Type to None.
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4. Follow your prompts and <D> to identify the center of the circle, then <D> to place a point 
on the circle.

Note: As we started a new drawing the zoom area may be larger or smaller. Your drawing 
may not look exactly as shown below due to this; simply place the first circle then 
window area around the element.

5. <R> when done.

6. In the Tool Settings box, toggle on Diameter and key in a 
value of 5.

Note: Important! Don’t forget to tab after keying in the value. Otherwise, your entry will 
not be accepted. This is true for all fields in MicroStation dialog boxes.
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7. <D> to identify the center of the 5 ft. diameter circle.

8. <R> when done.

9. Practice placing circles with other diameter or radius values.

10. In the Tool Settings box, set Method to Edge and toggle off the Diameter or Radius 
constraint.

11. Follow your prompts and <D> to place a circle by specifying three edge points. <R> when 
done.
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12. In the Tool Settings box, set the Method to Diameter and follow your prompts to place a 
circle with two points for the diameter. <R> when done.

Place Arcs and Shapes

1. In the CDOT Menu, set the Category, Filter and Item to establish the correct level and 
symbology.
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2. From the CDOT Main tool palette, select the Arc icon.

3. In the Tool Settings box, set the Method to Start, Center.

4. Follow the prompts and <D> anywhere to place the first arc endpoint.

5. <D> to define the arc center.
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6. <D> to define the second endpoint.

7. <R> when done.

8. In the Tools Settings box, set the Method to Start, Mid, End.

9. Follow the prompts to place an arc by 3 points.
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10. Repeat the above step, but place the arc in the opposite direction.
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11. Using any of the available methods, constrain the radius by clicking in the check box as 
shown, and place another arc.

12. Try setting other constrains and place additional arcs.

13. <R> when done.
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14. In the Main tool bar, select the Place Shape icon.

15. <D> to place vertices for an unconstrained shape.
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16. For the last data point (to close the shape), select Close Element.

17. In the Tool Settings box, set Fill Type to Opaque and place another shape.

18. Set Fill Type back to None. 
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19. On the Polygons toolbar, select Place Block.

20. <D> for the first corner of the block.

21. <D> for the opposite corner.

22.  Place a few more blocks until you’re comfortable with the command.

Lab 5.3 - Delete and Undo

Delete an element

1. Fit View 1.
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2. From the CDOT Main toolbar, select Delete Element. 

3. Move your cursor over the orange line until it highlights.
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4. <D> to delete.

Undo and Redo the deletion

1. From the Standard toolbar, select Undo.

The line reappears.

2. Select Redo.

The line is deleted again.

Note: You can also choose Edit > Undo to reverse the previous action and get a 
description of what you are undoing.
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In addition to the Delete command, the Undo/Redo commands work for most 
MicroStation drawing tools.

If you have elements that are close to or on top of each other, <R> until the element you 
want to delete highlights, then <D> to delete.

Lab 5.4 - Change the Element Highlight Color

1. Select Settings > Design File > Color.

2. Set Element Highlight Color to Yellow. 

3. Select OK.

4. Choose Delete Element from the Main toolbar.

5. Move your cursor over an element until it highlights.

6. Notice the highlight color is now yellow.

7. <D> to delete the element.

The Delete Element command remains active and you can continue deleting elements.

8. Set the highlight to a color you prefer.

Lab 5.5 - Delete all

1. Select Edit > Select All to put all elements you’ve drawn in a MicroStation selection set.

2. Choose Delete from the Main toolbar.

3. All elements selected are deleted.
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LAB 6 - Draw the Median Island Nose Section

In this lab, you’ll draw the nose section shown below using AccuDraw and precision keyins.

1. If AccuDraw is docked, as shown below, drag the AccuDraw Window and float it in the 
view.

Note: If AccuDraw is not on, toggle it on from the Primary toolbar. 

If your compass is set to Polar mode, below left, switch it to Rectangular mode, below 
right, by pressing <spacebar> on the keyboard.

            

Lab 6.1 - Draw a Concrete Gutter Pan Section

1. On the CDOT Menu, set the Explorer to Drafting, the Category to Linework, the Filter to 
WT and select Item Weight 1.

2. Key in xy=1000,1000 to define the starting coordinate for drawing the section (the upper 
left corner).

Note: If you can’t see the line’s endpoint and it is “rubber banding” into the view, Zoom 
Out and then reset once <R> back into the Place Line command.  If you zoom 
with your mouse wheel, you don’t have to reset.

3. Set your cursor to slope down and to the right to establish the direction.

[
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4. Use the AccuDraw’s rectangular compass to place the median’s 8 ft. gutter pan at a 1:12 
slope. Key in 8 for X and 8/12 for Y. (The Y value updates to -0.667). Make sure your 
cursor is set to slope down before entering the values.

Note: Remember, do not move your cursor into the AccuDraw window to key in your 
values; you may lose your positive/negative axis orientation.  The focus (blinking 
cursor) is already set for you in the X field – just start typing!  Then, <Tab> or 
arrow down to the next field.

  

5. <D> to place the point.

6. Zoom in, if necessary, to see the line.

Note that the compass rotates to the segment.  You actually want to place the next line from 
the horizontal axis, so you need to rotate the compass so that X is horizontal.

7. Press V on the keyboard to rotate the compass to the view. The X-axis (red tic mark) should 
now be horizontal.

8. Position your cursor up and to the right to establish the direction of the next segment.

9. Key in 2 for X and 2/12 for Y. (The Y value updates to 0.167 to establish the slope on the 
next line).

10. <D> to place the point.
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11. Press V on the keyboard to rotate the compass to the view.

12. Lock your cursor on the –Y axis by moving your mouse to the left and hitting enter; then 
key in .5 in the Y field for the next segment. <D> to place the point.

Note: You don’t have to key in the negative, AccuDraw knows the direction from your 
cursor location.

13. Press V on the keyboard to rotate the compass back to the view.

14. Lock your cursor on the –X axis and key in 10 in the X field. <D> to place the point.

15. Hover over the starting point of the median section. When you see the bold X, <D> to 
AccuSnap to the point to complete.

Draw the median cover

1. Fit the view.
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2. Select the Place Block command.

3. AccuSnap on the upper-left corner of the median.

4. Place your cursor down and to the left to establish the direction.

5. Using AccuDraw’s rectangular window, place a 2 ft. X 4 in. block as shown. Key in 2 for 
X and :4 for Y (don’t forget the colon in front of the 4 to specify inches.) <D> to place the 
point.

6. <R> when done.

Draw the pavement section

1. While still in the Place Block command, AccuSnap on the upper-right corner of the con-
crete section.

a. Using AccuDraw, place a 3.5 ft X 6” block as shown.

2. In the Place Block Tool Settings, toggle Fill Type to Opaque.
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a. Use AccuDraw to place two 1.5 ft X 3 in. and one 6 in. X 3 in. filled blocks to create 
the pattern as shown. 

3. Set Fill Type back to None.

Draw the subgrade section

1. Select the Place SmartLine tool.

2. AccuSnap on the lower-right corner of the asphalt to start the subgrade.

3. Use the information above to place the SmartLine using AccuDraw.

4. To practice drawing these lines again using precision keyins, Delete the two lines you just 
placed to start over.

5. Re-draw the two lines using the dx= precision keyin (delta keyin).

♦ AccuSnap to the starting point.

♦ Key in dx=,-:6 for the first line.
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♦ Key in dx=-15.5 for the second line.

Note: Don’t forget the negative signs. You could also key in .5 instead of :6 and 15:6 
instead of 15.5.

6. Again, Delete the two lines you just place to start over.

7. Re-draw the two lines using the di= precision keyin (distance, direction keyin).

♦ Select the Smartline command

♦ AccuSnap to the starting point

♦ Key in di=:6,-90 for the first line

♦ Key in di=15.5,180 for the second line

♦ AccuSnap to the location shown to finish

Note: You don’t need the negative signs because of the direction you move the mouse.

8. Fit the view.

You’ve now used MicroStation’s two main techniques for precision placement – precision 
keyins and AccuDraw.  By using each method, you can compare the two methods and 
determine which you prefer.

You’ll practice more with precision keyins and AccuDraw in other labs.

9. Save Settings (File > Save Settings).

10. Exit MicroStation.
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LAB 7 - Place Guardrail lines 

In this exercise, you’ll place guardrail lines in the design model file and then work with the custom line styles. 

Chapter Objectives:

After completing this exercise you will know how to:

♦ Use the CDOT Menu to place custom lines styles

♦ Change the direction of a directional line style

♦ Change the elevation of an element after placement

♦ Change the level on which an element was placed

♦ Update graphics to ByLevel Symbology

Lab 7.1 - Open the Design Model File

1. From the MicroStation Manager, open the 12345DES_Model.dgn file from the 
\Design\Drawings\Reference_Files folder

Note that the aerial photo raster images are attached.

2. Select the Raster Manager Icon from the Primary toolbar, or you may select File > 
Raster Manager.

3. Select both raster images, 09a.tif and 10a.tif, and turn off their display in View 1.
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4. Select the View Attributes icon from the view toolbar and toggle Off Line Styles 

Lab 7.2 - Draw the Guardrail

Next, you’ll follow the steps below to place guardrail along the fill area approaching the 
intersection.

Create the guardrail trace lines

Create temporary lines using the Move/Copy Parallel command.

1. Window in to the area to the left of the intersection around station range 212+00 – 216+00 
as shown.
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2. Pull the Manipulate toolbar off the Main toolbar.

3. Select the Move Parallel tool off the Manipulate toolbar.

4. In the Tool Settings box:

♦ Toggle on Distance and key in 2.

♦ Toggle on Make Copy.

5. <D> on the red Edge of Oil line on the upper (North) side of the road.

6. Move your cursor up to establish the direction for the parallel copy.
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7. <D> to copy the Edge of Oil line.

8. Repeat the above steps to create a guardrail trace line for the lower (South) side of the road. 
Be sure to parallel copy the Edge of Oil line.

Trim the trace line for the extent of the guardrail

1. On the CDOT Menu, select Drafting > Linework.

2. Set the Line Weight category to 1.

Note: This should automatically select the Place SmartLine tool.
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3. On the Status bar, turn Off Depth lock. 

Note: Make sure that Depth lock does not have a check mark beside of it to ensure that 
it is off.

4. On the Status bar, set the active snap mode to Perp.

5. <D> on the guardrail trace line you just copied.

As you move your cursor, note how you can only place perpendicular to the trace line.
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6. AccuSnap on the endpoint of the Toe of Fill line as shown to draw the perpendicular line.

This will serve as the cutting element for the trace line. The guardrail starts at the beginning 
of the toe of fill line.

7. <R> when done.

8. Repeat the above steps to create a trim line for the other side of the road and be sure to 
AccuSnap to the end of the toe of fill line.



Colorado Department of Transportation   Page 183

Labs for MicroStation XM LAB 7 - Place Guardrail lines 

9. Select the Extend Element to Intersection command.

10. Follow your prompts and <D> on the trace line on the side of the element to keep, to the 
right of the perpendicular line.

11. <D> on the perpendicular line to trim the trace element to this point.



Page 184 Colorado Department of Transportation

LAB 7 - Place Guardrail lines Labs for MicroStation XM

<D> to accept. 

12. Update your view, if necessary.

13. Repeat to trim the lower side as shown.

14. Delete the blue perpendicular trim lines.

Check the Depth lock

1. <T> on the left end of the upper trace line.

Note that the trace lines were copied at the same elevation as the edge of oil lines. When 
you place the guardrail lines, you want to place them at an elevation of 0.

Note: If you want the guardrail lines to pick up the correct elevations of the roadway 
surface, you can drape them with InRoads.

2. Key in az=0

3. <D> anywhere in the view to set the active depth.
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Note: The CDOT defualt active depth is set to 0.

4. Select the Locks button from the Status bar.

5. Turn Depth lock On.

With Depth lock turned on, you will place elements at the active depth instead of picking 
up the elevation of elements you snap on.

6. Toggle AccuSnap Off.

It’s always a good habit to turn AccuSnap off when using Depth lock.

Place the guardrail lines

1. On the CDOT Menu, select Design from the Explorer Window.
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2. Set the Category to Guardrail and select the item Type 3 left.

Note: This automatically sets the active level to DES_GUARDRAIL_Type‐3_Left with all 
ByLevel settings (color, style and weight), and automatically selects the Place 
SmartLine command. Note that the ByLevel style is a directional custom line 
style called GUARDRAIL_Left_Proposed.

3. <T> on the left endpoint of the upper trace line as shown.
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Check the message field. Note that with Depth lock on, you’re placing the line at a Z value 
of 0 instead of the elevation of the line’s endpoint.

4. <D> to accept.

5. Pan or Zoom to locate the other endpoint of the trace line near the intersection.

Note: Remember when using View Controls in the middle of a drawing command, reset 
<R> once to get back to the command.

6. Snap (<T>, then <D>) on the right endpoint as shown.

7. <R> when done.
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8. Select Settings > View Attributes and toggle on Line Styles.

9. On the CDOT Menu select Guardrail Type-3 Right.
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10. For the South side of the road we will use a different method. Select the Change 
Element Attributes from the Main Toolbar.

11. From the Tool Settings window toggle on Use Active Attributes, as well as Level, Color, 
Style, and Weight, this will use the the correct guardrail line as selected from the CDOT 
menu.
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12. Select the South guardrail line.

Note: We have changed the attributes of the trace line to be the new guardrail line. Some 
custom line styles, like these, depend on the direction they are drawn. If the new 
guardrail line is placed in the wrong direction (the posts should be on the outside),  
select the Change Direction tool from the Misc. Tools toolbar.

Note: The Misc. Tools toolbar was created for CDOT using handy tools from within 
MicroStation. 

13. Select the South guardrail line.

Note: Since we simply changed the attributes of the line we offset, it remains at its 
original elevation. We must now change the elevation of the new element to 0.
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14. From the CDOT Menu, select CDOT Tools > ModElev.

15. From the Tool Settings window, type an elevation of 0 and select Single.

16. Select <D> the new guardrail line.

17. The elevation has been changed to 0. To check, snap <T> to the endpoint of the line and 
notice the elevation in the status bar. 

18.

19. Turn AccuSnap back On.
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Delete the North trace line

1. Select Delete from the Main toolbar.

2. Hover over on the trace line with your mouse.

Note: Watch for the trace line (not the guardrail line) to highlight. If you see the guardrail 
posts highlighted, <R> until the trace line highlights (watch for pop-up information 
to show the line on level DES_ROADWAY_Edge‐of‐Road‐Oil). 

When using the Delete command, use the reset button to select coincident elements.

3. With the correct line highlighted, <D> to accept. 

Lab 7.3 - Use the Element information to change levels

1. Select Element > Information or select this command from the Primary toolbar.

2. <D> on the upper Type 3 guardrail lines you’ve just placed.

3. Read the basic element information in the Message field.

This is the same as the pop-up information provided when you “hover” over an element 
with your cursor.

4. In the General section of the Element Information box review the element attributes and 
properties.
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5. Set the Level to DES_GUARDRAIL_Type_7.

The element is moved to the DES_GUARDRAIL_Type_7 level and the graphics update.

Note: Element Information is one way to change element attributes or properties if the 
element was originally placed incorrectly.

6. Select the Element Information command again and change the Level back to 
DES_GUARDRAIL_Type-3_Left and Apply.
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7. Select the Geometry section to review the element geometry.

Note: The element was placed at the CDOT default active depth of 0 in the 3D file. 

8. Close the Element Information dialog box when done.

Lab 7.4 - Turn Rasters Back On

1. Fit the view.



Colorado Department of Transportation   Page 195

Labs for MicroStation XM LAB 7 - Place Guardrail lines 

2. Select the Raster Manager icon from the Primary Toolbar and turn both raster files back 
on in View 1.

3. Fit your view if you don’t see the raster images.

4. Select File > Save Settings.
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LAB 8 - Create 3D Utility Graphics

In this example, you’ll create a Utility model file, work with references, and then place proposed 3D utility 
lines using the CDOT Menu and the parallel copy tool. You’ll also modify the graphics as necessary.

Chapter Objectives:

After completing this exercise you will know how to:

 Work with nested references

 Use the Copy Attachment option for references

 Use the CDOT Menu to place custom line styles (Utility lines).

 Place elements in 3D using Depth Lock
 Manipulate elements using the Parallel Copy tool

 Modify elements using the Trim tools

Lab 8.1 - Create the Utility model file

1. Open the MicroStation Manager and set the Project to 12345.

2. Set the directory to \Utilities\Drawings\Reference Files.

3. Open the file 12345UTIL_Model.dgn. The blank Utility model file opens.

4. Select File > Save As...

5. Set the Directory to \Utilities\Working.
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6. Change the file name to CU12345UTIL_Model.dgn and select Save.

The new file is created in the Working folder.

Lab 8.2 - Attach references

1. Select References from the Primary toolbar.
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2. From the References dialog box, select Tools > Attach and select the 
12345DES_Model.dgn file from the \Design\Drawings\Reference Files folder.

3. Verify the Attachment Method is set to Interactive and select Open.
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4. In the Attachment Settings box, keyin a Logical Name of Design and a Description of 
Design Model Plan. Make sure Display Raster Reference is on. Set the other options as 
shown and select OK.

5. Fit the view.

The Design reference graphics, along with the raster photos, appear in the Utility model 
file.

Lab 8.3 - Raster Images

Since Display Raster References was turned on when attaching the reference, the aerial photos 
were attached with the design model file (they were turned on in the Design Model file from 
the last lab). You can quickly turn them off from the Reference dialog instead of opening the 
Raster Manager.
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1. In the References box, highlight the Design reference and toggle Display Raster Refer-
ences off.

Lab 8.4 - Work with reference files

1. Window in on the Intersection.
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2. On the Reference dialog, change No Nesting to Live Nesting and set Depth to 1 and 
click on the Show Hierarchy icon.

3. In the Hierachy pane, select the Design reference file as shown below. On the right, select 
the Survey/Topo nested reference and make sure that Display is toggled on.
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4. Open the Level Display box, make sure the Show Target Tree button is On, and select the 
Survey/Topo Reference. Right click on the bottom pane and choose All On to turn on all 
reference levels.

The nested Survey/Topo graphics are displayed.

5. Back in the Reference dialog box, select the upper-level CU12345UTIL_Model.dgn 
master file in the Hierarchy pane. On the right, select the 12345DES_Model.dgn 
reference and toggle off Display.

Both Design and Survey/Topo are turned off since Survey/Topo is nested.
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6. Turn the display of the Design reference back On.

7. How would you turn off the Design graphics and leave the Survey/Topo graphics on? 
Currently, as nested references, you can’t do this. However, in the next section you will 
accomplish this using Copy Attachment.

Use the Copy Attachment option

Many times, especially in Model files, you want all your references to be upper level references 
(as opposed to nested references) so that you can turn on/off the display of individual reference 
files. To accomplish this you can either reference all the nested files one by one or you can use 
the Copy Attachment option.

1. With the Design reference selected on the right, change the Live Nested option to Copy 
Attachment.

 

Note: Notice that in the Heirarchy pane of the References dialog box both the Design and 
the Survey/Topo references are now upper level references. As a result of changing 
Live Nesting to Copy Attachments, the nested Survey/Topo reference was copied 
in as a direct attachment.
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2. On the right-hand side of the References box, select the reference for the Design model 
and toggle the Display off.

With both references as direct attachments, each reference cand be individually turned on/
off. In this example the Design reference is turned off while the Survey/Topo graphics 
remain on.

Note: As a rule of thumb for Model files, you can reference nested to avoid having to 
attach multiple times. Then, once the nested references are attached, use the Copy 
Attachment option to make all nested references direct attachments. For Sheet 
files (see Chapter 9), you should typically use nested attachments.

3. Turn the Design reference display back On.
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Lab 8.5 - Drawing in 3D (using Depth lock)

In the next series of steps, you will practice placing utility graphics from the CDOT Menu with 
and without Depth lock. The Depth lock sets the elevation of the graphics are placed in a 3D 
file.

Place overhead electrical lines

1. To check your active depth, key in az=$ then <D> in the view.

The default active depth for the CDOT for the Utility model file is 0.00.

Select the Locks button on the status bar and verify that Depth lock is turned Off.

With Depth lock turned off, you will pick up the elevation of elements you snap to in a 3D 
file.

2. Zoom in on the south side of the intersection cross road.

3. On the CDOT Menu highlight the Utilities group and set Status to Proposed.

4. Select the Electric category.

5. Set the Filters category to All.
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6. Select the Overhead Line item.

Note that the active level is automatically set to UTIL_ELECTRICAL_Overhead and the Place 
SmartLine command is started.

7. AccuSnap to the end of the existing North/South overhead line at the power pole as 
shown.
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8. AccuSnap to the end of the existing east/west overhead line at the power pole as shown.

9. <R> to complete this line.

10. Turn Off the display of the Topo/Survey reference to better see the proposed graphics.

11. <T> on the end of the proposed overhead electrical line you just placed.

Note: Even though the active depth is 0, since Depth lock is turned off the line was 
placed at the elevation of the existing overhead line (6627.317).

12. <T> on the other end of the proposed overhead electrical line to check its elevation.

Place proposed gas lines

1. Turn Off the display of the Design reference and turn On the display of the Survey/Topo 
reference.

2. On the CDOT Menu, select the Gas category.
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3. Select the Gas Line item.

4. <T> on the end of the existing gas line on the east side of the road.

5. Place data points to draw the gas line in the approximate location shown.

6. <R> when done.
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Note: The line does not look as expected. <T> on the East end of East-West section of the 
newly placed gas line and note the elevation.

<T> on the West end and note the elevation

<T> snapping to an existing element positions the starting point of the new element at the 
elevation of the original element. Subsequent points that are not snapped to are placed at 
the Active Depth (Elevation) of 0. In this case, what you see is a proposed gas line that goes 
from an elevation of +/- 6622 to an elevation of 0 making the utility much longer than it 
should be. Because there are now so many “G” symbols in a line that is over 6000’ long, it 
gives the appearance of a thick line.

7. Delete the proposed gas utility line you just placed.

8. Select the Locks from the status bar.

9. Toggle On Depth Lock.
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10. On the Snap Mode toolbar, toggle AccuSnap Off.

Note: AccuSnap doesn’t work consistently when Depth Lock is on. Therefore, to ensure 
Depth lock works correctly, toggle AccuSnap off.

11. Place the proposed gas line again by a <T> on the end of the existing gas line and then 
placing the other data points in the approximate location shown.

12. <T> anywhere on the proposed gas line you just placed and note the elevation.

Since Depth lock is on, the proposed gas line was placed at an elevation of 0.

Note: To return to the default settings, turn Depth lock Off and toggle AccuSnap back 
On.

Place fiber optic lines using parallel copy

Follow the steps below to place a fiber optic line by copying parallel an existing telephone line.

Locate reference graphics for copying

1. Turn off the TOPO_TERRAIN_Break-Lines level in the SurveyTopo reference.
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2. Window in on the existing overhead electrical line in the southeast quadrant of the 
intersection as shown.

3. Select the Move Parallel tool from the Manipulate toolbar.

4. In the Tool Settings box, set the options as shown below.

5. <D> on the existing overhead line

6. Move the cursor down to specify the direction of the parallel copy.



Colorado Department of Transportation   Page 213

Labs for MicroStation XM LAB 8 - Create 3D Utility Graphics

7. <D> to place the copy.

Note: When copying graphics from a Topo file, elements will maintain a hard coded 
linestyle scale and thus appear at the incorrect scale.  This scale needs to be 
adjusted using the Element Info tool. In this example the linestyle scale of the new 
utility line need to be changed from a value of 100 to 1.

8. Select the new graphic and <D> on the Element Info tool.

9. Expand the Extended category and Line Style Parameters sub-category.

10. Change the value of the Scale option to 1.

11. Close the Element Info
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Change element attributes

Change the overhead electrical line to an underground fiber optic line using the Change  
command.

1. Set the active level to UTIL_FIBEROPTICS (hint: use a filter to help you set the level).

2. Select the Change Element Attributes command from the Change Attributes toolbar.

3. Set Method to Change.

4. Toggle On Use Active Attributes.

5. Toggle On Level (this picks up the active level).

6. <D> on the overhead electrical line you just copied as the element to change.

7. <R> when done.
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Since the Use Active Attributes option was turned on, the element was changed to the 
active level UTIL_FIBEROPTICS.

Set the elevation

1. <T> on the fiber-optics line you just placed.

The proposed fiber-optics line is in the 6615 elevation range (your exact elevation may be 
vary depending on where you placed a tentative point). This elevation is wrong for the fiber 
optic line since you copied the overhead electrical line. For now, you can set the elevation 
of this line to 0 and later, it can be placed as a feature in the InRoads surface at the correct 
elevation. One way to set the elevation of an element is to use the ModElev command on 
the CDOT Menu.

2. On the CDOT Menu, select CDOT Tools > ModElev.

3. In the ModElev tool settings box, set the elevation to 0.

4. Select Single (to identify a single element).

5. <D> on the new fiber-optics line you created.

6. <D> to accept.

7. <R> when done.
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8. <T> on the fiber-optics line to check its elevation.

The Z value is now at 0. Use the ModElev command to easily set the elevation of any 
element or group of elements (selected with a fence).

Trim graphics

The new fiber optic line is only going in on the east side of the intersection cross road. 
Follow the steps below to use the Extend Element to Intersection command to trim the 
fiber optic graphics.

1. Select the Extend Element to Intersection command from the Modify toolbar.

2. <D> on the fiber optic line to the right of the intersection, this is the section we wish to 
keep.
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3. <D> on the north/south proposed overhead electrical line as the cutting element.

The fiber-optics lines are trimmed as shown.

4. Turn off the display of the Survey/Topo references.

5. Fit the view.

Only the proposed gas, electric and fiber-optic utility graphics should appear in the 
CU12345UtilityModel01.dgn file. 
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6. Turn the display of the Design reference On and window into the intersection as shown.

Move the utility model to the Reference Files folder

Move the utility model so that other groups can reference your work.

1. Select File > Save As and set the directory to the project’s 
\Utilities\Drawings\Reference_Files folder.
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2. Remove the CU initials from the file name and select Save.

The file is saved to the new location.

Note: The project template delivers standard dgn’s for model and sheet files as starter 
files.  Use caution when when prompted to confirm saving over an existing file as 
you could lose data.

3. Select File > Close.

4. In the MicroStation Manager verify that the file was saved to the Reference_Files folder.
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5. Set the directory to \Utilities\Working.

6. Right-click while hovering over the file and select Delete to delete the file from the 
Working folder.

7. Cancel the MicroStation Manager to exit.
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In this lab you’ll create a Landscape & Environmental (L&E) model file and then use the CDOT Menu to place 
silt fence lines, hay bale cells and wetlands regions.

Chapter Objectives:

After completing this exercise you will know how to:

 Use the CDOT Menu to place L&E custom lines

 Use the CDOT Menu to place L&E cells

 Use the CDOT Menu to place L&E shapes (wetlands)

 Use the CDOT Menu to pattern areas

Lab 9.1 - Create the L&E Model File

1. Start MicroStation.

2. Re-set Project to 12345.

3. Set the directory to \Landscape_Environmental\Drawings\Reference Files.

4. Select the file 12345LAND_ENVI_Model.dgn and select Open.

5.  After opening the file, select File > Save As… and set the directory to 
C:\Projects\12345\Landscape_Environmental\Working.
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6. Change the file name to CU12345LAND_ENVI_Model.dgn and select Save to save a copy 
to the Working folder.

7.  Select References from the Primary toolbar.

8. Using what you’ve learned, attach the Design model reference (from Design’s 
\Drawings\ Reference_Files folder), Coincident-World and at a 1:1 scale. Copy 
Attachments at a depth of 1 to bring in the Survey/Topo as direct attachments. See below. 
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9.  Fit the view.

10. From the Reference dialog, Turn off the display of Design’s raster references.

 Place silt fence

1. Window around the end of the project just east of the existing bridge.

2. From the CDOT Menu, select the Landscape Environmental Group.

3. Set Status to Proposed.

4. Set the category to Erosion Other / Sediment Control.
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5. Select the Silt Fence item.

This automatically sets the active level to LAND_ENVI_Erosion-Silt-Fence and selects the 
Place SmartLine tool.

6. Place data points to draw the silt fence along the toe-of-fill line on the south side of the 
proposed road (similar to the one shown).

7. <R> when done.

Place Haybales

1. Set the category to Checks / Silt Dike.
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2. Select the item No Plot Line.

This automatically sets the active level to DRAFT_INFO_No-Plot and selects the Place 
SmartLine tool. The No Plot level allows you to place a construction line representing the 
location of haybales, silt dikes, etc. that you can later divide with a cell.

3. Place data points to draw the haybale construction line on the north side of the proposed 
road as shown.

4. <R> when done.
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5. On the CDOT Menu, select Settings and set Active Scale to 100, Apply and then Close.

6. Set Placement to 50’ Spacing.

7. Set the item to Haybale.

This automatically selects the Place Cell command and starts the Cell Divide program.

8. When prompted to Identify Element, <D> on the No Plot line you just placed.
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9. <D> to accept.

The No Plot line is divided with the haybale cells at 50 ft. intervals.

Create wetlands

Draw the wetland shapes

1. Pan over to the left to the area around the bridge as shown.

2. From the Reference File dialog box turn on the display of the Survey/Topo file.
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3. Open Level Display, highlight the Survey/Topo reference, right-click in the list of levels 
and turn on all of the Survey/Topo reference levels.

4. On the CDOT Menu, set the category to Wetlands.
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5. Select the item Wetland Right.

This automatically sets the active level LAND_ENVI_Wetland-Right and selects the Place 
Shape tool.

6. Place data points to define the wetlands region as shown. To close the shape, select Close 
Element in the Place Shape Tool Settings box.
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7. Repeat for the area on the other side of the bridge as shown.

Pattern the wetlands 

8. On the CDOT Menu, select the Mitigation item from the Wetlands category.

This automatically selects the Pattern Area command and sets the active pattern cell.

9. When prompted, <D> on the wetland shape you just drew and then <D> to accept.

10. Repeat for the other wetlands shape on the north side of the bridge.
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11. Turn off the display of the Survey/Topo reference.

12. Save Settings.

13. Proceed to the next lab.
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Chapter Objectives:

After completing this exercise you will know how to:

 Use the CDOT Menu to place Hydraulics custom lines (pipes)

 Use the CDOT Menu to place Hydraulics cells (inlets)

 Use the CDOT Menu to place Hydraulics terminators (RCES)

Lab 10.1 - Create the Hydraulics Model File

1. In MicroStation, select File > Open.

2. Set the directory to \12345\Hydraulics\Drawings\Reference Files

3. Select the file 12345HydraulicsModel##.dgn and select Open.

4. Select File > Save As… and set the directory to \Hydraulics\Working
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5. Change the file name to CU12345HydraulicsModel.dgn and select Save to save a copy to 
the Working folder.

6. Select References from the Primary toolbar.

7. Using what you’ve learned, attach the Design model reference (from Design’s 
\Drawings\ Reference_Files folder), Coincident-World and at a 1:1 scale. Copy 
Attachments at a depth of 1 to bring in the Survey/Topo file as direct attachments. See 
below. 

8. From the References dialog, turn off the display of the design model’s raster references.

Place Inlets

Using known coordinates and the CDOT Menu, place proposed Type R inlets along the curb 
flowline at the end of the project.
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1. Window into the area shown near the end of the project.

This area of the projects is a proposed 2-Lane urban section with curb, gutter and sidewalk. 
You’ll first place inlets along the curb flowline.

2. Select Locks from the status bar and make sure Depth lock is turned off.

3. On the CDOT Menu, select the Hydraulics Group.

4.  Set the Status to Proposed, select the Inlets (Plan) category, and then select the Type R L 
10 item.

Note: This automatically sets the active level to HYDR_Inlets and selects the Place Cell 
command. The inlet cell is attached to your cursor at the origin point. Since you 
know the coordinate location for the inlets, you can place them with precision 
keyins.
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5. Select Settings and set Active Scale to 1 and Active Angle to 180.  Apply and then 
Close.

6. For the 1st inlet, key in xy=3292424.652, 1553316.387, 6351.8

The inlet appears in the location shown.

Note: If you don’t see the inlet, it could be outside your display depth. Key in 
dp=0,7000  Enter, and then select the view. You could also fit the view and then 
window back to this location.

7. For the 2nd inlet, key in xy=3292674.652, 1553320.404, 6350.4

8. For the 3rd inlet, key in xy= 3292900.384, 1553324.031, 6348.8

9. <R> to exit the Place Active Cell command
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10. Turn off the Design reference levels shown to better see the inlets.
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Connect the inlets with pipes

Place the pipes

1. Zoom in on the first inlet.

2. Verify that Depth lock is still turned off.

When placing pipes, you want to pick up the elevation of the inlets, therefore you need to 
turn Depth lock off.

3. On the CDOT Menu, set the category to Pipes (Plan).

4. Select the item Reinforced Concrete.
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Note: This automatically set the active level to HYDR_PIPES_Concrete and selects the 
SmartLine tool.

5. AccuSnap on the right-side midpoint of the inlet to begin the pipe.

6. Pan to the right and AccuSnap on the left-midpoint of the second inlet.

7. Pan to the right and AccuSnap on the right-midpoint of the third inlet.

8. <R> when done.

Note: This connects the inlets with the concrete pipe. Notice how the directional arrow 
on the pipe custom line style falls on top of the last inlet. You can correct this by 
shifting the custom line style.

Shift the line

1. Select the Change Element Attributes toolbar from the Main toolbar.

2. Select the Modify Line Style Attribute command.

3. Set the Modify option to Shift.
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Note: The Shift command is also located on the CDOT Misc. Toolbar.

4. <D> on the concrete pipe that you just placed and move your cursor to the left. Note how 
the custom line style shifts as you move your cursor. When the arrow is moved off of the 
inlet, <D> to accept.

Note: Use the Modify Line Style command to shift custom lines styles as needed, 
especially in corners where there may be gaps.

Place a Type C inlet and connect pipes

Turn on the Survey/Topo reference

To help determine the location of the inlet, turn on the Survey/Topo Reference and the Contour 
reference. 

1. On the Reference dialog, select the Design reference set the Copy Attachment Depth to 
2.

Note: This brings in the Contour reference since the Contour model file is referenced to 
the Survey/Topo file.

2. Be sure the display of all other reference files are off.
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Turn on reference levels

1. In the Level Display box, turn on all of the Survey/Topo reference levels.



Page 242 Colorado Department of Transportation

LAB 10 - Create Hydraulics graphics Labs for MicroStation XM

2. Turn on all Contour reference levels.

3.    Window into the location shown.
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4. On the CDOT Menu, select the Inlets (Plan) category and then select the Type C item.

Note: This automatically sets the active level to HYDR_Inlets and selects the Place Cell 
command. The inlet cell is attached to your cursor at the origin point. 

5. Key in xy= 3292986.899, 1553291.431, 6347.0

6. <R> to exit the Place Active Cell command.

7. On the CDOT Menu, set the category to Pipes (Plan) and select the Reinforced Concrete 
item again.

8. Key-in AZ=6346 then <D> in the view to set the active depth to 6346.0. This will allow the 
placement of the pipe outlet at the correct elevation.

9. AccuSnap on the right-midpoint of the last Type R L 10 inlet.
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10. Select the Origin snap mode and AccuSnap on the Type C inlet. (see below).

11. Place a final <D> in the location shown for the end of the pipe near the contour line (see 
below).

12. <R> when done.
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13. Use the Modify Line Style again command and Shift the pipe line style as necessary to 
ensure the arrow does not fall on top of an inlet.

Place the pipe terminator

The pipe terminates at a 36” RCES, which you can place as a cell line terminator.

1. On the CDOT Menu, set the category to FES (Plan).

2. Set Type to Concrete – Round.

3. Select the 36 inch item.
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Note: This automatically set the active level to HYDR_FES and selects the Place Active 
Line Terminator tool from the Cells toolbar.

4. <D> on the end of the concrete pipe as shown.

5. <D> to accept.

Note: The RCES terminator is automatically rotated to the appropriate angle and placed 
on the end of the pipe.

6. Save Settings.

7. Exit MicroStation.
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In this lab, you’ll practice all of the drawing concepts you’ve learned so far to create a bridge typical section.

Chapter Objectives:

After completing lab 11, you will know how to:

 Use the Bridge Menu to set active attributes (level, color, line style, weight).

 Use basic drawing tools (AccuDraw, AccuSnap, Modify and Manipulation tools, cells, 
patterns, etc.) to draw a bridge typical section and a reinforcement detail.

 Use Selection Sets to group graphics.

Lab 11.1 - Create a Bridge Model file for details

Note: Since you have already selected xxMulti‐Discipline from the Select Group utility, you 
have access to all Bridge levels. However, you could also select the Bridge Group 
before starting MicroStation to limit your levels to just those needed for Bridge.

1. Start MicroStation.

2. In the MicroStation Manager dialog box, re-set Project to 12345.

3. Set the directory path to \Bridge\Drawings\Reference_Files.
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4. Select the file 12345BRDG_Model.dgn and then select Open.

The blank model file opens.

5. Select File > Save As… and set the directory to the project’s \Bridge\Working folder.

6. Rename the file CU12345BRDG_Detail.dgn and select Save.

Note: Note that you are renaming this file from “Model” to “Detail”. 

The file is copied to the working folder with the initials CU (CDOT User, for training 
purposes).
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7. Select Settings > Design File > Working Units and set the Format to MU:SU.

8. Select OK to change the coordinate readout. Your readout will now show values in feet and 
inches.

Lab 11.2 - Draw a bridge typical section

In the next series of steps, you’ll use AccuDraw and MicroStation tools (drawing tools, 
manipulation and modify tools, grouping tools, etc.) to create the bridge typical section 
shown.

You’ll begin by drawing construction lines on a drafting level, and then create the final detail 
on the appropriate bridge level.

Draw the slab construction lines

You’ll draw the right side of the top of slab starting at the crown point of the road. The right 
side consists of a 12 ft. travel lane and a 6 ft. shoulder, both at a 2% cross slope.

1. On the CDOT Menu Drafting group select the Linework category.
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2. Set the filter to WT and select Weight 1.

This sets the active level to DRAFT_WT‐1.

3. <D> anywhere to place the first point.

4. Make sure your AccuDraw compass is in Rectangular mode. If it is not press 
<spacebar>.

5. In the SmartLine Tool Settings box, make sure Rotate AccuDraw to Segments is turned 
Off.

This will keep the X axis horizontal as you draw SmartLine segments.

6. Move your cursor down and to the right to establish the direction of the SmartLine.

7. In AccuDraw, key in 12 for X, then <TAB>.

8. In AccuDraw, key in 12*.02 for Y, then <TAB>.

9. <D> to place the first SmartLine segment.

10. Zoom In if needed to see the line.



Colorado Department of Transportation   Page 251

Labs for MicroStation XM LAB 11 - Draw a Bridge Typical Section

Note: Do not reset out of the SmartLine command. This will break the SmartLine, which 
you do not want to do. You want the top slab line to be all one element.

This creates the 12 ft. travel lane at a 2% slope.

11. For the next shoulder segment, move your cursor down and to the right to establish the 
direction of the SmartLine.

12. In AccuDraw, key in 6 for X, then <TAB>.

13. In AccuDraw, key in 6*.02 for Y, then <TAB>.

14. <D> to place the second SmartLine segment, this creates the 6 ft. shoulder at a 2% slope.

15. <R> out of the SmartLine command.

Create the bottom slab construction line

Vertically copy the top slab line down 8 inches for the bottom of slab on the right side.

1. Select the Copy command from the Manipulate toolbar.

2. AccuSnap on the right end of the top slab to identify the element to copy.

3. Move your cursor down and lock on to the –Y AccuDraw axis to establish the copy 
direction. In AccuDraw, key in :8 for Y and the press <TAB> to accept the entry. The value 
converts to 0.667 feet.
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Note: Don’t forget to key in the colon before the 8 to specify 8 inches. 

4. <D> to place the copy, then <R> to complete.

Create the slab left side

Since the right and left sides of the road are symmetrical, you can mirror the right side to create 
the left side.

1. Select the Element Selection command and set the Tool Settings as shown.

2. Place a fence around the slab graphics (<D> for upper left corner and then <D> for lower 
right corner).

3. Select the Mirror command from the Manipulate toolbar:

♦ Set Mirror About to Vertical.
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♦ Toggle on Make Copy.

4. <D> on the left endpoint of the upper slab line (the crown point) for the mirror copy.

5. <R> when done.

6. Select the Element Selection command again and select the Clear icon from the tool 
settings window to remove the selection set.

7. Fit the view.

Place the girders

1. On the CDOT menu, select the Bridge Group.

♦ Set the Category to Bridge Levels
♦ Set the Type to Basic
♦ Select the Outline item

Note: This changes the active level from a DRAFT level to the BRIDGE_OUTLINE level for 
placing the girders.

2. On the CDOT menu, select the Bridge Group.

♦ Set the Category to Cells
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♦ Set the Type to Girders-BT
♦ Select the BT54 item

Note: This automatically selects the correct girder cell from the bridge cell library and 
activates the Place Cell command.

3. On the CDOT menu, select the Settings button

♦ Set Active Scale to 1
♦ Set Active Angle to 0
♦ <D> Close to exit the Settings window

4. Using AccuDraw we can establish an orientation point from which to place the first girder. 
With the girder cell attached to your cursor, hover over right endpoint of the bottom slab 
line (don’t AccuSnap, just hover and lock on to the point).

5. Click into the AccuDraw box to set it active and press the letter O on the keyboard to move 
the AccuDraw compass origin to this point.

6. Move you cursor to the left to establish the placement direction, and key in 3:6 in the X 
field.
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7. With your cursor locked on the X axis <D> to place the girder cell.

This places the first girder 3 ft. – 6 in. from the right side of the slab. You’ll later move the 
girder down for the proper haunch depth.

Place additional girders

Copy the girder cells to space them 7 ft. 3 in on center.

1. Select the Copy command.

2. In the Tool Settings box, key in 4 for the number of copies.

3. Click into the AccuDraw window to set it active.

4. <D> on the girder at the top midpoint.

5. Move your cursor to the left to establish the copy direction and key in 7:3 in the X field in 
AccuDraw.
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6. With your cursor locked on the X axis, <D> to place the copies.

Move the girders down to establish the haunch depth

1. Select the Move command from the Manipulate toolbar.

2. Click into the AccuDraw window to set active.

3. <D> on the right end girder at the top midpoint for the move from location.

4. Move your cursor up and lock on the Y axis to establish the direction, then press <Enter> 
on the keyboard.

By pressing <Enter> you “smartlock” the AccuDraw X and Z axes, so that you can only 
move in the Y direction.

5.  Press N on the keyboard for the Nearest snap mode.
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6. Hover over (do not data point) at the nearest snap point on the bottom slab line.

7. Press the letter O on the keyboard to move the AccuDraw origin to this point.

8. Move your cursor down to establish the move direction, lock on to the ‐Y axis and key in :4 
in the AccuDraw Y field.

9. <D> to move the girder.

This moves the girder down 4 inches from the bottom of the slab for the correct haunch 
thickness.
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10. Repeat the above steps to vertically move the remaining girders down 4 inches from the 
bottom of the slab.

Place the Bridge Rail

1. On the CDOT menu, select the Bridge Group.

♦ Set the Category to Bridge Rail
♦ Select the Rail Type 7 item

2. AccuSnap on the left end of the top of slab as shown.

3. For the right-side rail, select the Place Active cell command again.

4. In the Tool Settings box, Unlock the XYZ lock and set the X scale to -1.

Note: -1 X-axis scale will mirror the cell about the X axis.
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5. Place the cell as shown.

6. <R> when done.

Extend elements

Extend the slab lines to join up with the bridge rail. To do this, you’ll need to drop the bridge 
rail cell to its original elements.

1. Select the Drop command from the Groups toolbar.

2. Select Drop Element, and toggle on Complex (the cell is considered a complex 
element).

3. <D> on the right-side bridge rail cell.

4. The cell is dropped to its original elements.
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5. Select the Extend Elements to Intersection from the Modify toolbar.

6. <D> on the bottom slab line and then <D> on the back of rail line to extend these elements.

7. Repeat the above steps for the right side.

Draw the slab

1. With the active level set to BRIDGE_OUTLINE, select the Place SmartLine tool.

2. Click in the AccuDraw window to set it active.

3. Starting on the left side, AccuSnap on the bottom of the bridge rail.

4. You want the next point to be 1” below the left-top of the first girder. To do this, you’ll 
need to move the AccuDraw origin to the top of the girder and then locate 1” down.
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5. Hover over the left-top of the girder as shown, click in the AccuDraw box and press the   
letter O on the keyboard to move the AccuDraw origin to this point.

6. Move your cursor down, lock on the Y axis and key in a value of :1 (1 inch).

7.  <D> to place the SmartLine segment.

8. AccuSnap on the left-top of the girder as shown.

Note: Remember, if you make a mistake, Undo  the last data point, don’t reset out of 
the SmartLine command.
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9. AccuSnap on the right-top of the girder as shown.

 

10. Move your cursor up, lock on to the Y axis and press <Enter> to smartlock the axis. You 
can now only move in the Y direction.

11. Press N on the keyboard for the nearest snap point.

 

12. <D> on the bottom slab line as shown.

13. Hover over the next girder’s top-left endpoint as shown.

14. Press O on the keyboard to move the AccuDraw origin to this point (do not data point).

15. Move your cursor up, lock on to the Y axis, and press <Enter> to smartlock the axis.

16. Press N for the nearest snap point.

17. <D> on the bottom slab line as shown.
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18. <D> on the top left girder edge as shown.

19. Continue these steps on each girder to place SmartLine segments as shown until you get to 
the last girder location shown below.

Remember to Undo, not reset, if you make a mistake on a segment.

20. On the last girder (far right), move your cursor down, lock on to the Y axis and key in a Y 
value of :1 (1 inch).

21. <D> to place the point.
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22. <D> on the right end of the bottom slab line.

23. <R> out of the Place SmartLine command.

24. Select the Extend Element to Intersection tool from the Modify toolbar.

25. <D> on the blue top of slab line and then <D> on the back of bridge rail line to extend 
these elements.

26. Repeat for the left side.

27. Delete the blue bottom of slab lines.
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28. Fit the view.

Create the top of pavement

1. Fit the view.

2. Select the Copy command.

3. <D> on the right-side top slab line (blue construction line) at the crown point to select it for 
copying.

Note: If you select the bridge slab shape (red element), <R> until the top slab line 
highlights.

4. Move your cursor up and lock-in on AccuDraw’s Y axis.

5. In AccuDraw, key in a Y value of :3 (3 inches).

6. <D> to copy the top slab line.

7. Repeat for the left side.

Note: You can move your cursor up and lock in on the last distance tic mark of 3 inches, 
eliminating the need to key in the Y value.

8. On the CDOT menu, select the Bridge Group.

♦ Set the Category to Bridge Levels
♦ Set the Type to Outline
♦ Select the Outline-Asphalt item
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This sets the active level to the asphalt level.

9. Change the top of pavement lines to the active asphalt level.

Clean-up lines at the rails

You now need to trim the top of pavement lines that run through the bridge rails, as well as the 
bottom of the rail that extends below the top of slab. 

1. Select the IntelliTrim command from the Modify toolbar.

2. Set the Mode to Quick and the Operation to Trim.

3. <D> on the vertical edge of the rail to select it as the cutting element, as shown below.
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4. Draw a crossing line on the top of pavement line inside the rail as the portion to trim.

5. Repeat the above steps for the left-side rail.

Lab 11.3 - Complex the bridge rail graphics

Since you dropped the bridge rail cell to trim the graphics it is no longer one entity. Instead it 
was dropped to individual lines. You will now group the lines into a complex chain.

1. Select the SmartMatch command and <D> on any red bridge line to match it.

This sets the active level to Bridge_Outline to match the slab.

2. Select Create Complex Chain from the Groups toolbar.

3. Set the Method to Automatic and toggle on Simplify Geometry.
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Note: With the Automatic method, you do not have to individually identify each element 
to add to the complex chain. The elements are found automatically within a 
maximum gap range. Simplify geometry will make the new element a SmartLine 
instead of a complex element.

4. <D> on the first segment of the bridge rail as shown.

5. <D> anywhere above this element to define the direction for adding elements. The 
remaining bridge rail elements are added to the chain and placed on the active 
Bridge_Outline level.

6. <D> to accept.

7. Repeat for bridge rail on other side of bridge.
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Note: With some MicroStation commands (like the Complex Chain command), if you 
hover over the complex element it will still show you the individual elements that 
make up the chain. However, notice that pop-up information tells you it really is a 
complex chain. When you use the Copy command in the next step, you’ll see the 
chained elements behave as one element.

8. Select the Copy command from the Primary toolbar and copy the bridge rail to a clear 
area of the design file.

The individual graphics are now chained together into one element.

9. Undo the copy.

Note: You can use the Create Complex Shape in a similar fashion to create closed shapes 
from individual graphics.

Lab 11.4 - Create a Selection Set of the Bridge Section

1. Fit the view.

2. Choose the Element Selection tool from the Main toolbar.

3. Hold down the data button <D> and drag across the bridge section (corner to opposite 
corner). Be sure to include all of the section graphics in this area.
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Note: The elements are added to the selection set and are highlighted purple (the 
selection set color). To change the color, choose Settings > Design File > Color 
> Selection Set Color. The lower right corner of the status bar shows how many 
elements are now in the selection set.

4. <D> in the center of the typical section, hold down the data button and drag the selection 
set to a new location in the file.

5. Drag the selection set back to its original location.

6. <D> anywhere in a clear area of your design file to remove the selection set.

Note: The selection set is a temporary group of graphics until you drop the set.

Lab 11.5 - Create a Graphic Group of the Bridge Section

1. Use the Element Selection tool and place the bridge typical section graphics into a 
selection set again.

2. From the Groups toolbar, select Add to Graphic Group.

3. <D> to accept the selection set element to add to the group.

4. <R> out of the command.

5. <D> anywhere in a clear area of your design file to remove the selection set. The elements 
“un-highlight” and return to their normal symbology.
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6. On the status bar, check your locks and make sure Graphic Group lock is On.

7. Select the Move command.

8. <D> on the bridge typical section graphics. All elements in the graphic group highlight.

9. Move the graphics and a new location and <D> to accept. With Graphic Group lock On, 
the elements behave as a group.

10. On the status bar, turn the Graphic Group lock Off.

11. Select the Move command again.

12. <D> on one of the BT 54 girders. Only the girder highlights.

13. Move it to a new location and <D> to accept.

With the Graphic Group lock Off, you can manipulate the individual elements in the group.

14. Undo the Move command on the girder.

15. Turn the Graphic Group lock back On.

16. Move the bridge typical section graphics back to their original location.
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Note: When working in design model files, most InRoads graphics are displayed as 
graphic groups (e.g. contours, profiles, cross sections).

Pattern pavement and slab

1. Fit the view.

2. On the CDOT menu, select the Bridge Group.

♦ Set the Category to Bridge Levels
♦ Set the Type to Basic
♦ Select the Pattern item to set the active level

3. From the CDOT Menu Explorer:

♦ Select Drafting.

♦ Set the Category to Patterning.

♦ Select the Concrete item.
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4. In the Pattern Area Tool Settings box set the Method to Flood,  Active Scale to 1 and the 
Active Angle to 0.  

5. Make sure the entire region to flood is shown in your view. Then, <D> anywhere inside the 
bridge slab region. The region to flood with the pattern highlights.

6. <D> to accept. The shape is patterned with the concrete cell.
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7. Select the Hatch Area command from the Patterns toolbar.

8. In Tool Settings, select the Flood method, set Spacing to :3 and the Angle to 45.

9. <D> anywhere inside the pavement area. A dynamic display shows the flooded area.

10. <D> to accept. The region is flooded with the hatch pattern.
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11. Save Settings.

12. Exit MicroStation.
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Intersection

Several plan/profile sheets have already been created using the InRoads Plan/Profile Generator. However, 
there are times when you need to create special plan or plan/profile sheets not created by the Generator. In this 
lab, you’ll create a plan/profile sheet for the side road that runs through the intersection.

Chapter Objectives:

After completing this exercise you will know how to:

 Create a sheet file using a generic project file.

 Attach model files coincident-world

 Attach model files as saved views.

 Rotate the view to horizontal

 Use the CDOT Menu to place a border and associated information (bar scale, north arrow, 
region cell, etc.)

 Use the CDOT Menu to place a clipping boundary.

 Clip references

 Work with reference levels.

 Move references

Lab 12.1 - Review Plan/Profile Sheets

Review the Plan/Profile sheets for this project previously created by the InRoads Plan/Profile 
Generator.

1. Start MicroStation.
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2. In the MicroStation Manager, open 12345DES_PnP10.dgn from the project’s 
…\Design\Drawings folder.

The InRoads Plan/Profile Generator automates the creation of sheet files along the 
mainline alignment. This includes rotating the plan-view to horizontal, placing the 
corresponding profile, placing the border, north arrow and match lines. MicroStation 
references are used to bring in plan and profile graphics to the active sheet file.

3. Use Level Display to review the reference levels on which plan and profile graphics are 
placed in the sheet file.

Note that the only levels with graphics in the sheet file are sheet levels for the border, 
match line, north arrow, etc.

4. Open other plan/profile sheets, as desired, from the Drawings folder and review the sheets.
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Lab 12.2 - Create a New Sheet File

Since the InRoads Plan/Profile Generator did not create a sheet for the county cross road at the 
intersection, you’ll create this P&P sheet file manually.

5. Select File > New.

6. Set the directory to the project’s  \Design\Drawings folder.

7. In the New box, make sure that the seed file is set to 3D-Seed_CDOT.dgn. If not, pick 
the Browse button and then select this file. Key in the name 12345DES_PnP19.dgn.

Nineteen is the next number in the plan/profile set of sheets.

Select Save to create the file.

Lab 12.3 - Attach the Model file

8. Select the Reference icon from the Primary Tools toolbar.

9. In the References dialog box, select Tools > Attach.
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10. Use the Directory pull-down menu and select the 
C:\Projects\12345\Design\Drawings\Reference_Files folder and select the file 
12345DES_Model.dgn

11. Verify the Attachment Method is set to Interactive. Select OK.  

12. In the Reference Attachment Settings box:

♦ Key in a logical name of Design and Proposed Intersection for a description.

♦ Verify that Orientation is set to Coincident-World and the Scale is set at 1:1 

♦ Set Nested Attachment to Live Nesting and set Depth to 1.
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♦ Turn off Display Raster References.

13. Select OK.

Note: The Coincident World option ensures that references are attached with their true 
coordinate information. A scale factor of 1:1 ensures that plan graphics are 
referenced in actual size. These two options allow plan sheet graphics to maintain 
their true model coordinates and size. 

14. Turn on the Show Hierarchy to expand the hierarchy list.
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Note: Note that with nested references, the Survey/Topo reference is nested below the 
Design model file. You can typically reference model files as nested to sheet files 
instead of using the Copy Attachment command (as in this case, you want to show 
both Design and Survey/Topo graphics in the sheet file). However, if you need to 
control individual references in the sheet file, then use the Copy Attachment 
command.

15. Close the References dialog.

16. Fit View using the icon so all graphics are displayed. 

17. Select File > Save Settings from the menu.

Lab 12.4 - Rotate the View using the 3-point method

Rotate the view so that the side road appears horizontal in the view.

1. Window around the intersection as shown.

2. Select the Rotate View command and set the Method to 3 Points.

3. Follow your prompts and AccuSnap on the end of the PI leader line shown.

4. For the second point (X axis of the view), AccuSnap on the POE leader line.
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5. For the third point (Y direction), <D> anywhere to the left of the first two points. 

The view is rotated so that the side road appears horizontal. 

Note: Remember that you are rotating the view, not the graphics. The graphics maintain 
their original coordinate position in the sheet file. 

Note: The leader lines are both placed at elevation 0. If you pick points at different 
elevations, you’ll need to first turn on Depth lock before choosing the 3-Point 
rotation command to avoid a skewed rotation.



Page 284 Colorado Department of Transportation

LAB 12 - Create a Plan/Profile Sheet for the Intersection Labs for MicroStation XM

Lab 12.5 - Place the Border Cell

6. Zoom out as shown.

7. From the CDOT Menu Explorer, select Drafting and then select the Border category and 
choose the Border (PnP 11”x17”) Item.
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8. Select Settings and set Active Scale to 100 and 
Active Angle to 0.    

Note: Coordinate with the Region Surveyor when you are creating sheets that are not at a 
1:100 scale.  They will provide you with the topography and survey MicroStation 
files at a different scale.  Otherwise, the line work and cells will not be the correct 
size for the print scale.     

The Active Angle is view independent and not associated with view rotation. Therefore, the 
x-axis is always horizontal regardless of the view rotation.  You will not need to set this for 
correct placement of the North Arrow or other cells.

9. Select Apply and Close in the Active Settings box.

10. When prompted to locate the cell origin of the sheet border, <D> in the approximate 
location shown to place it. Don’t worry about an exact location – you’ll move it in the next 
step.
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11. If necessary, use the Move command and move the border cell so that the intersection is 
centered in the upper plan portion as shown.

Lab 12.6 - Placing a Clip Boundary

1. From the CDOT Menu Explorer select Drafting. 

 Set the Category to Border
 Select the Item Clip Boundary
 Verify the SHEET_Clip‐Boundary level is active.
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Note: Since Plot is turned off for the level SHEET_Clip‐Boundary in the Level Manager, 
it will not print.

The Place SmartLine command is now automatically selected, allowing you to draw an 
irregular closed shape that represents your clipping boundary of the model file. However, if 
your clipping boundary is a rectangle, you can use the Place Block command.  

2. Select the Place Block icon from the Main toolbar and draw the clipping boundary as 
shown (corner to opposite midpoint on the blue inside margin).

Lab 12.7 -  Clip the Reference File

1. In the References dialog box, highlight the Design reference.

2. Select the Clip Reference icon.

Note: You can select more than one reference file at a time by holding the <Shift> or 
<Control> keys down while you are making your selection.  You can clip 
multiple drawings in one step when they are all selected.      
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3. In the Tool Settings box, verify Method is set to Element.

4. When prompted to Identify Clipping Element, <D> on the rectangular clipping boundary 
you just placed. 

5. <D> to accept.

6. Fit the MicroStation view and Save Settings after clipping the reference files. 

Note: Once the clipping boundary is placed, do not delete it.  The clipping region of the 
reference file will be lost if the boundary is deleted.

In the next Chapter, you’ll edit the border text to add project specific information. 

Lab 12.8 - Turn off the Profile Grid and Text

1. Open the Level Display box and turn Off the following levels:

 SHEET_Grid

 SHEET_Grid‐Minor

 SHEET_Grid‐Text

This turns off the border’s grid for the profile. You’ll use the grid provided by the InRoads 
profile.



Colorado Department of Transportation   Page 289

Labs for MicroStation XM LAB 12 - Create a Plan/Profile Sheet for the Intersection

Lab 12.9 - Attach the Design Profile

1. In the References dialog box, select Tools > Attach.

2. Use the Directory pull-down to navigate to the 
C:\Projects\12345\Design\Drawings\Reference_Files folder and select the file 
12345DES_Prof03.dgn

3. Verify the Attachment Method is set to Interactive. Select Open.  

4. In the Reference Attachment Settings box:

 Set Orientation to Top
 Key in a Logical Name of Profile Side Road and Proposed profile for side road 

as the Description.

 Set Scale to 1:1
 Set Nested Attachment to No Nesting.

5. Select OK.
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6. The outline of the profile reference is attached to your cursor. <D> in the approximate 
location shown to place the profile.

Move the profile reference

Since you attached the profile reference by a top view, it did not come in at a precise location.  
Next, you’ll move the profile to line it up better with the plan.

1. Turn on AccuDraw if it’s not already on.

2. Highlight the Profile in the Reference dialog and select the Move Reference icon or 
select Tools > Move.

♦ Click into the AccuDraw window to set it active.
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♦ Snap to the left end of the vertical alignment (the first VPI) as the Move From point.

Move your cursor to the left along AccuDraw’s X axis to set the focus (blinking cursor) in 
the AccuDraw X field, then Press Enter.

Note: The Enter key executes AccuDraw’s SmartLock.  It locks the Y and Z axes to 0 so 
you can only move in the X direction.
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 Move your cursor and AccuSnap on the end of the shoulder line as shown.  You can 
zoom in, if needed. 

The beginning of the vertical alignment is now aligned with the beginning of the horizontal 
alignment.

3. <R> when done.

4. Fit the MicroStation view.
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Lab 12.10 - Place the bar scale, north arrow and RE cells

Follow the steps on the next page and use the diagram below to place the various border cells.

1. From the CDOT Menu Explorer, select Drafting.  Set the Category to Border.

2. Select the Item Scale Horizontal.

3. When prompted to locate the cell origin of the Bar Scale, <D> inside the sheet border.
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4. Select the Item North Arrow Standard

5. When prompted to locate the cell origin of the North Arrow, <D> inside the sheet border.

6. Set the Category to Border RE.

7. Select the Item Default.
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8. When prompted to locate the cell origin of the Region Engineer cell, Zoom in as necessary 
on the bottom portion of the border and <T> to the correct location and then <D> to accept.  

Lab 12.11 - Turn On the Reference Display

1. On the References dialog, select the Survey/Topo reference nested under the Design Ref-
erence.

2. Toggle on Display for the Survey/Topo reference.

3. Use Level Display to turn On all Survey/Topo levels.

4. Fit the view.

5. Save Settings.
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Lab 12.12 - Optional Exercise

Change the Design reference’s nested depth to 2 and turn on the display of the contour 
reference – 12345SURV_Contour100.dgn. Use Level Display to turn On the contour levels 
to display the existing contours in the plan sheet. 
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In the last section, you placed a generic border for your plan/profile sheet from the CDOT menu. This is handy 
when you have only one or two sheets to create since you have to edit the border with project specific 
information for each sheet. But what if you had several sheets to create? You wouldn’t want to edit every sheet 
to add the project information. Instead, you can create a project-specific border that can be used for all sheets 
of the same type. This way, you only have to fill in the project information one time.

Chapter Objectives:

After completing this exercise you will know how to:

 Create a project-specific border cell library.

 Use the CDOT Menu to place the border and associated information.

 Edit the border text to place project-specific information.

 Make the border graphics a cell.

Lab 13.1 - Create the Border File

Since you will use this border for multiple sheets, create one project border to avoid editing 
multiple borders later.

1. In MicroStation Manager, select File > New.

2. Set the directory to C:\Projects\12345\Miscellaneous.

3. Verify the Seed File is set to 3D-Seed_CDOT.dgn, if not then select it as the seed file.

4. In the Name field, key in a drawing file name 12345DesignPlanBorder.cel.

Note: The .cel extension denotes this file as a cell library.

5. In the New dialog box, select Save. 

6. The file you created will be highlighted. Select Open to open that file.
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Lab 13.2 - Use the CDOT Menu to Create the Border

1. From the CDOT Menu Explorer, select Drafting and set the Category to Border.

2. Select the Item Border (Plan 11”x17”)

3. Select Settings and set Active Scale to 1 and Active Angle to 0.    

Note: You will create the generic project border cell at a scale of 1 (11 x 17 master units). 
You’ll actually scale the border, according to your plot scale, later when the cell is 
placed in the sheet file.

4. Select Apply and Close in the Active Settings box.

5. <D> to place the border anywhere in the blank file.

6. Set the Category to Border RE.

7. Select the Item Default.
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8. Fit the view.

9. When prompted to locate the Region Engineer cell, <D> to the location shown.

Note: You will not place the bar scale and north arrow cell now, but later in each 
individual sheet.

Move the border

The lower left corner of the border must be located at the 0,0 coordinate in the file since this 
will be the origin of the cell. So, move it to this location.

1. Place a Fence block around the entire border.
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2. Select the Move command and toggle on Use Fence.  Set the mode to Inside.

3. Snap to the lower-left corner of the yellow block (outside edge) as the move from point.

4. Key in xy=0,0 as the move to point.

5. The border moves to the new location.

6. Reset <R>.

7. Fit the view.

8. <T> on the lower-left edge to verify it’s at 0,0.

Lab 13.3 - Edit the Border Text with Project Specific Information

1. Zoom in on the lower-right corner of the border as shown.
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2. Select the Edit Text command from the Text toolbar.

3. <D> on the Project Number text.

4. In the Text Editor, replace this with STA 086A-039.

5. <D> anywhere to accept.

6. <D> on the Code text.

7. In the Text Editor, replace this with 12345 and <D> to accept.

8. Edit the X’s beside Designer and replace with your initials (CU is used in the illustration, 
but you can use yours).

9. <D> anywhere to accept.

10. Edit the X’s beside Detailer and replace with your initials.

11. <D> anywhere to accept.

12. Fit the view.

Lab 13.4 - Make the Border a Cell

1. Select Models from the Primary toolbar.
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2. In the Models dialog box, select Edit Model Properties.

3. In the Model Properties box:

♦ Toggle on Can be placed as cell.
♦ Change the Name to 12345 Design Plan Border.

♦ Change the Description to Project Border Cell.

♦ For Ref. Logical key in Plan Border.

♦ Leave all other options as shown

4. Select OK.

5. Close the Models box.

6. Save Settings (File > Save Settings).

7. Exit MicroStation.
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The CDOT default scale for plan sheets is 100. This lab illustrates how to create a special 40-scale plan sheet 
for the intersection.

Chapter Objectives:

After completing this exercise you will know how to:

 Create a Plan sheet

 Scale the border for a 40-scale drawing

 Set the Annotation Scale to match the border and plot scale.

Lab 14.1 - Open the Model File 

1. Start MicroStation and open 12345DES_Model.dgn form the project’s \Design\Draw-
ings\Reference_Files folder.

2. Select File > Raster Manager and turn off the display of the raster files.

3. Fit the view.

4. Window around the intersection as shown.
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Lab 14.2 - Determine the rotation angle for the sheet

1. On the CDOT Drafting Menu, set Line Weight to 3.

2. Using AccuDraw, draw temporary horizontal line in the approximate location shown.

3. Select the Measure Angle command from the Measure toolbar.
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4. <D> on the horizontal line, then <D> on the SH86 proposed centerline.

MicroStation displays the result as approximately 15 degrees. This is the rotation angle 
needed to rotate the view to horizontal at the intersection in a counter-clockwise direction. 

5. Delete the temporary measurement line.

Lab 14.3 - Placing the Plan Limits Cell

1. Select Cells form the Primary toolbar to open the cell library.

2. Toggle on Display All Cells in Path and select the SHEET_Design-Plan-Limits cell and 
make it the active placement cell.
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Note: This cell helps to define the plan sheet limits in the model file before placing the 
border in the sheet file. It contains text characters that can be edited to indicate 
sheet name, rotation, & scale. The outer line-work depicts the maximum display 
limits for graphics as it relates to the border sheet. The inside shape reflects ½ inch 
inside this maximum limit and is the clipping boundary. All graphical information 
for this cell is on to the MicroStation level, DRAFT_INFO_No-Plot.

3. Close the Cell Library dialog box.

4. Turn on the level DRAFT_INFO_No-Plot if it is not currently on.

5. Select the Place Active Cell command and set the Active Angle to -15 and the Scale to 
40.

Note: The scale should be set to the plot scale of the sheet. Since the positive angles are 
measured counterclockwise in MicroStation, enter the 15 degree angle as negative. 
MicroStation converts this to a positive 345 degree angle.
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6. Place plan limit cell in the approximate location shown.

7. Select the Edit Text command and <D> on the text at the bottom of the cell.

  

8. In the Text Editor, make the edits as shown.

9. <D> anywhere in the view to accept.
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Lab 14.4 - Create the Drawing File

1. From the MicroStation menu bar, select File > New. 

2. Set the directory to C:\Projects\12345\Design\Drawings.

3. Verify the Seed File is set to 3D-Seed_CDOT.dgn, if not then select it as the seed file.

4. In the Name field, key in a drawing file name 12345DES_Plan21.dgn

5. In the New dialog box, select Open. The Open button is used to accept the new file name 
and open the drawing at the same time.

6. The file you created will be highlighted. Select Open to open that file.

Lab 14.5 - Attach the Model File

1. Attach the 12345DES_Model.dgn reference from the C:\Proj-
ects\12345\Design\Drawings\Reference_Files folder (use the Directory pull-down to 
quickly find the folder).

2. Verify the Attachment Method is set to Interactive. Select Open.  

3. In the Reference Attachment Settings box:

 Key in a logical name of Design and Proposed Intersection for a Description.  

 Verify that Orientation is set to Coincident-World and the Scale is set at 1:1 

 Set Nested Attachment to Live Nesting and set Depth to 1.

4. Select OK.
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5. Fit the view.

 

6. Turn on the Show Hierarchy and expand the hierarchy list.

Note that with nested references, the Survey/Topo reference is nested below the Design 
model file.

The Survey/Topo file that is attached nested to the Model file is for a 100 scale plot. 
However, you’re creating an intersection sheet at a 40 scale. Therefore, you need to attach 
the correct scale Survey/Topo reference.

Note: Coordinate with the Region Surveyor when you are creating sheets that are not at a 
1:100 scale.  They will provide you with the topography and survey MicroStation 
files at a different scale.  Otherwise, the line work and cells will not be the correct 
size for the print scale.

7. Select the Design model reference and change the nesting to No Nesting to remove the 100 
scale Survey/Topo reference.
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8. Attach the 12345SURV_Topo40.dgn file from the project’s 
\ROW_Survey_Drawings\Reference_Files folder with the options shown.

9. Fit the view. 

Lab 14.6 - Rotate the View 

Rotate the view so that the portion of the mainline alignment through the intersection 
appears horizontal in the view.
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1. Window around the intersection as shown.

2. Use the Rotate View, 3-Point method to rotate the view so that the plan limits cell is 
horizontal to the view

Note: You can also use the keyin rv=,,15 since you know the rotation angle from the 
plan limits cell. The commas are used as placeholders since you are not rotating 
about X and Y axis. You are only rotating about the Z axis – the perpendicular axis 
to the Top View.
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The view is rotated so that the alignment appears horizontal.

Note: Remember that you are rotating the view, not the graphics. The graphics maintain 
their original coordinate position in the sheet file.

Lab 14.7 - Attach the Border Cell

1. Select Cells from the Primary toolbar.

2. In the Cell Library dialog box, select File > Attach and navigate to the 
C:\Projects\12345\Miscellaneous folder.

3. Select the 12345DesignPlanBorder.cel file.

This is the project-specific border created earlier.
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4. Select Open to attach the cell library.

The cell library only has one cell (model) – the 12345 Design Plan Border that you 
previously created.

5. Select Placement to make the border the active placement cell.

6. Close the Cell Library dialog box.

Lab 14.8 - Place the Border

1. Select Place Active Cell from the Cells toolbar.

2. In the Tool Settings box, set Active Angle to 0 and the Active Scale to 40 for X, Y and 
Z.

Note: The Active Angle is view independent and not associated with view rotation. 
Therefore, the x-axis is always horizontal regardless of the view rotation.  You will 
not need to set this for correct placement of the North Arrow or other cells.



Page 314 Colorado Department of Transportation

LAB 14 - Create a 40-scale plan sheet Labs for MicroStation XM

Note: The Active Scale scales the border up 40 times around the full-sized graphics to 
match the plot scale.

3. AccuSnap on the lower left corner of the plan limits cell as shown to place the border.

4. <D> to place the cell.

5. <R> to exit the command.

Lab 14.9 - Place the Clip Boundary

1. From the CDOT Menu Explorer select Drafting.

2. Set the Category to Border.

3. Select the Item Clip Boundary .
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4. Select the Place Block icon from the Main toolbar and draw the clipping boundary by 
snapping on the opposite corners of the plan limits cell as shown (interior most line).

Lab 14.10 - Clip the Reference File

1. In the References dialog box, highlight both the Design and Survey/Topo references for 
clipping.

2. Select the Clip Reference icon.

3. In the Tool Settings box, verify Method is set to Element.

4. When prompted to Identify Clipping Element, select the rectangular clipping boundary 
you just placed. 

5. <D> to accept.
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6. Fit the MicroStation view and Save Settings after clipping the reference files. 

Note: Once the clipping boundary is placed, do not delete it.  The clipping region of the 
reference file will be lost if the boundary is deleted.

Lab 14.11 - Place the Bar Scale and North Arrow

1. From the CDOT Menu Explorer, select Drafting.

2. Set the Category to Border.

3. Select the Item Scale Horizontal.
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4. When prompted to locate the origin of the Bar Scale, <D> inside the sheet border as shown 
below.

5. Select the Item North Arrow Standard.

6. When prompted to locate the North Arrow, <D> inside the sheet border as shown. 

Lab 14.12 - Set the Text Scale Factor

Set the Text Scale Factor to match the border and plot scale factors.

1. Select Models from the Primary toolbar.

2. In the Models box, select Model Properties.
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Note the Annotation Scale is set to 1:100 – the CDOT default.

3. Change the Annotation Scale to 1:40.

4. Select OK.

5. At the Alert message, select Yes to propagate the changes.

6. Close the Models box.

The Annotation Scale for the file now matches the border and plot scales. Later, when 
text and dimensions are placed in this file, they will be the correct size.

Lab 14.13 - Edit the Bar Scale

1. Window in to the bar scale cell.

2. Select the Edit Text command from the Text toolbar.

3. <D> on the X’ text on the bar scale.

4. Change the text to 20’ and <D> to accept.
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5. Make the other edits as shown.

6. Fit the view.

7. Save Settings.

8. Exit MicroStation. 
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Normally, all graphics are created in the model file and referenced to the sheet file. The sheet file contains the 
border, annotations and dimensions. However, typical section sheets are an exception to this rule.

Roadway Design typical sections can be created with the CDOT Typical Section Generator Program. The 
Generator Program not only creates the graphics, but it also annotates and dimensions the typical section. It 
uses a Text Scale Factor of 10 for all text. Therefore, the program must be run in a sheet file set up at a 10 
scale. The auto-populated file JPC#DES_TyplSect##.dgn is automatically created with the text scale factor set 
to 10 and the border placed at a 10-scale. Therefore, run the Typical Section Generator in the sheet file.

Chapter Objectives:

After completing this exercise you will know how to:

 Create a Typical Section sheet.

 Attach a project-specific border cell library.

 Use the Replace Cell command to replace a generic border with a project border.

 Use the CDOT Typical Section Program to automatically create a typical section based on 
input values.

 Use AccuDraw and “SmartLock” to align graphics.

 Save the typical section input file.

Lab 15.1 - Create a New Sheet File

1. Start MicroStation and open the file 12345DES_TyplSect##.dgn from the 
\12345\Design\Drawings folder.

The file opens and contains the generic border.
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2. Select File > Save As… and rename the file to 12345DES_TyplSect01.dgn and select 
OK.

The file is copied to the Drawings folder with the new name.

Lab 15.2 - Attach the Border Cell Library

1. Select Cells from the Primary toolbar.

2. In the Cell Library dialog box, select File > Attach and navigate to the 
C:\Projects\12345\Miscellaneous folder.

3. Select the 12345DesignPlanBorder.cel file.

4. This is the project-specific border created earlier.

5. Select Open to attach the cell library.

The cell library only has one cell (model) – the 12345 Design Plan Border that you 
previously created.

6. Select Placement to make the border the active placement cell.

7. Close the Cell Library dialog box.
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Replace the border

1. Select Replace Cells from the Cells toolbar.

2. In the Tool Settings box

♦ Set Method to Replace
♦ Set Mode to Single
♦ Toggle on Use Active Cell

3. When prompted to Identify Cell, <D> on the Typical Section Border.

4. <D> to accept.

The generic border is replaced with the project border.
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Lab 15.3 - Edit the Border Text for a Typical Section Sheet

1. Select the Edit Text Command from the Text toolbar.

2. <D> on the Plan Sheet text.

3. Change the text to Typical Section.

4. <D> to accept.

Lab 15.4 - Check Model Properties

1. Select File > Models from the menu (or select the Models icon from Primary Tools).

2. Select the Edit Model Properties icon 
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Note that the Annotation Scale factor is set to 1:10 for running the CDOT Typical Section 
Program. The text placed from the program will appear the correct size.

Note: You must change the Annotation Scale Factor if you run the Typical Section 
Program in any file other than the JPC#DES_TyplSect##.dgn file. 

3. Select the Measure Distance command and set the Distance to Between Points.
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4. Measure the height and length of the border (AccuSnap along the yellow edge).

Note that the border measure 110 x 170, or 10 times the actual size. If the border cell was 
scaled to a factor other than 1:10 (like 1:100 for a plan sheet), then it must be re-scaled or 
replaced at the proper scale of 10.

Lab 15.5 - Start the Typical Section Program

1. On the CDOT Menu, select Add On’s > Typical Section Program. 
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The CDOT Typical Section Program lets the user input different values based on the 
desired roadway section.  The various options are highlighted in blue. 

Note: Items that require input are shown in red.

Create a 2-Lane Rural Typical Section

1. On the Create Typical Sections dialog box, select Options > Writelock to toggle it On (a 
checkmark).

Note: If Writelock is On, permanent graphics will be generated in the file. If Writelock 
toggle is Off, the graphics are temporary and if you zoom or pan, the graphics will 
disappear.  A checkmark next to Writelock indicates that it is on.
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2. Set the Typical Section Program options as shown.

3. Select Apply.

4. When prompted to locate the profile grade point, <D> near the top-center of the sheet as 
shown.

The 2-Lane rural section is automatically drawn, annotated and dimensioned.
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5. Do not close the Create Typical Section dialog box.

Create a 2-Lane Urban Typical Section

1. Set the Typical Section Program options as shown.

2. Select Apply.

3. When prompted to locate the profile grade point, <D> near the bottom-center of the sheet 
below the first section.
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The 2-Lane urban section is automatically drawn, annotated and dimensioned.

4. Do not close the Create Typical Sections dialog box.

Save the 2-Lane Urban Section Input File

1. From the Create Typical Section dialog box, select File > Save.

2. Navigate to the C:\Projects\12345\Miscellaneous folder.

3. Key in a File name SH86_2L_Urban_Typical and select Save.

The input file is saved. If you need to generate this typical section again, Select File > 
Open form the Create Typical Section dialog box and select this text file. 

4. Close the Create Typical Section dialog box.

Align the Sections

Since you did not snap to a location for the sections, you may need to align the sections at their 
centerlines as well as move the section graphics into the border.

1. Place a fence block around the urban section.

2. Select the Move command from the Manipulation toolbar and toggle on Use Fence.
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3. AccuSnap on the centerline of the urban section as shown for the move from point.

4. Move your cursor horizontally (either to the right or left), lock on AccuDraw’s X-axis then 
press <Enter> on the keyboard.

This smartlocks the AccuDraw axis so that you can only move in the horizontal direction.

5. <D> on the rural section centerline as shown for the move to point.



Page 332 Colorado Department of Transportation

LAB 15 - Create a Typical Section Sheet Labs for MicroStation XM

The two sections are now aligned at the centerlines.

6. Fit the view.

7. Save Settings.

8. Exit MicroStation.
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at Different Scales

In this exercise, you’ll create a General Layout sheet using the bridge graphics drawn earlier. The exercise will 
demonstrate how to create a sheet with graphics at different scales.

Chapter Objectives:

After completing this exercise you will know how to:

 Place a border at a 40-scale.

 Create saved views in the model file for referencing to the sheet.

 Reference plan graphics coincident-world at 1:1

 Reference saved-view section and detail graphics at different scales on the same sheet

Lab 16.1 - Setup Bridge Model File

Open the bridge model file for plan

1. Start MicroStation.

2. Open the file CU12345BRDG_Model.dgn in the project’s \Bridge\Working folder.

The blank bridge model file opens.

Reference the Design Model file

1. Open Level Display and turn on the BRDG_TOOLS_Outline-Bridge level.

2. Fit the view.

The proposed outline graphics for the bridge have been already created in plan view.
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3. Attach the 12345DES_Model.dgn from the project’s 
\Design\Drawings\Reference_Files folder as shown. Attach Coincident-World at a 
Nesting Depth of 1. Do not attach raster references.

The design model is attached coincident to the proposed bridge graphics. A nested depth of 
1 also references the Survey/Topo file (currently the Survey/Topo display is off). You will 
later reference the bridge plan to a sheet file.

4. Zoom out as shown.

5. Save Settings.
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Move the Bridge Model to the Reference_Files folder

Since the work in the model file is complete, move from the Working folder to the 
Reference_Files folder so that other groups can reference, if needed.

1. Select File > Save As…

2. Set the directory to C:\Projects\12345\Bridge\Drawings\Reference_Files

3. Remove the CU (CDOT User) initial prefix and rename the file to 
12345BRDG_Model.dgn.

Note: Your initials are removed from the file when it is ready to transfer to the 
Reference_Files folder.

Note: The project template delivers standard dgn’s for model and sheet files as starter 
files.  You may be prompted to confirm saving over an existing file.  Please use 
caution when performing these tasks as you could lose data.  Be sure the files are 
empty or you are working with the latest files.

4. Select OK to save the file.

5. Select File > Close to return to the MicroStation Manager.
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6. In the MicroStation Manager, verify your 12345BRDG_Model.dgn file was copied to 
Reference_Files folder.

7. Change the directory to \Bridge\Working.

8. Select the CU12345BRDG_Model.dgn from the Working folder. Right click on the file 
and select Delete.

Note: Make sure you select the BRDG_Model file and not the BRDG_Detail file.

9. Select Yes to delete the working file if prompted to confirm deleting an existing file.

Open the bridge model file for section and details

1. Open the CU12345BRDG_Detail.dgn file from the C:\Projects\12345\Bridge\Working 
folder.

a. Create Saved Views

1. Fit the view.
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2. Make sure that only the section graphics are showing in the view. If not, Window around 
the bridge section. Be sure that the entire section encompasses the view and no other 
graphics are shown in the view.

3. Save the view by keying in sv=bridge section

4. When prompted, <D> to in the view to save it.

5. Select Utilities > Saved Views to open the Saved Views dialog box and verify that the 
view was saved.

6. Make sure the Graphic Group lock is turned off.

7. Select the Copy command and copy one of the BT 54 girder cells to the approximate 
location shown (outside of the section saved view).

This will be used as a reference on your details sheet.
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8. Window around the single girder you just copied to create a saved view for the girder 
detail. Make sure only the girder is shown in the view.

9. Key in sv=bridge rebar detail and <D> in the view to save.

Note: You can either use the sv= keyin or the dialog box option to create saved views.

10. Fit the view.

11. Save Settings.
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Move the model file to the Reference_Files folder

You’re finished working in this bridge model file, so move it to the Reference_Files folder.

1. Select File > Save As…

2. Set the directory to C:\Projects\12345\Bridge\Drawings\Reference_Files

3. Remove the CU (CDOT User) initial prefix and rename the file to 
12345BRDG_Detail.dgn.

4. Select Save to save the file.

5. Select File > Close to return to the MicroStation Manager.

6. In the MicroStation Manager, verify your 12345BRDG_Detail.dgn file was copied to 
Reference_Files folder.
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7. Change the directory to the \Bridge\Working folder. Right click on the file and select 
Delete to delete the CU12345BRDG_Detail.dgn file.

8. Select Yes to delete the working file if prompted to confirm deleting an existing file.

Lab 16.2 - Create the Sheet File

Create a new sheet file from a seed file.

1. In the MicroStation Manager, set the folder location to C:\Proj-
ects\12345\Bridge\Drawings.

2. Select the New File icon from the MicroStation Manager.

3. In the Seed File section, choose the Select button.

4. Select the seed file 3D-Seed_CDOT.dgn and select OK.
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5. In the Files field, key in the name 12345BRDG_Plan01.dgn.

6. Select Save.

The file appears in the folder list.

7. Select Open to open the file.

The empty file is created with all of the Bridge default settings from the seed file.
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Reference the Plan graphics

1. Reference the 12345BRDG_Model.dgn file from the \Bridge\Draw-
ings\Reference_Files folder. 

2. In the Attachment Settings box, set the options as shown and select OK.

The bridge plan and the nested design reference are attached to the sheet file. Since you 
attached at a 1:1 scale and Coincident-World, all of the bridge plan graphics are in their 
true coordinate locations and actual size.

3. Fit the view.
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4. Window in on the bridge area as shown.

5. Toggle off the display of the Design reference.

6. Only the graphics from the Bridge model are shown.
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Place the border

With the bridge plan graphics in place, you can now place the border around them.

1. Select Cells from the Primary toolbar.

2. Select File > Attach File and attach the 12345DesignPlanBorder cell library from the 
C:\Projects\12345\Miscellaneous folder.

3. Select the Placement option for this cell.

4. Select the Place Active Cell command and place the border at a 40 scale.

The border scale is the same as the plot scale of 1”=40’.
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5. <D> to place the border in the location shown. Be sure to position the border so that the 
bridge plan is in the upper left corner.

6. Turn on the display of the design reference.

7. On the CDOT Menu Explorer, select Drafting.

♦ Select the Border category.

♦ Select the Clip Boundary item.

8. Select the Place Block command and place the clip boundary block as shown.
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9. From the Reference dialog box, select the Bridge model reference and then select Tools > 
Clip Boundary.

10. <D> on the clip boundary to clip the design model reference. 

The bridge plan is now place inside the border at the proper coordinates. Design graphics 
levels can be turned on/off as needed.
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Reference additional graphics at various scales

Reference the typical section at a scale of 1” = 10’

1. From the References dialog, attach the file 12345BRDG_Detail.dgn from the 
\Bridge\Drawings\Reference_Files folder.

2. In the Attachment Settings box:

♦ Select the saved view Bridge Section (the logical name will update to the saved view 
name).

♦ Set the Scale to 40:10

Note: When working with multiple scales, always key in the border scale in the first field 
(Master) and the detail scale in the second field (Ref). MicroStation will calculate 
the scale for your, or you could calculate it yourself and enter 4:1.

♦ Set the other options as shown.
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3. Select OK and <D> to position the saved view reference in the location shown.

4. Reference the 12345BRDG_Detail.dgn again and repeat the above process and reference 
the bridge rebar detail at a scale of 1”=5’.
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Note: You’ll annotate and dimension this sheet in the next lab.

5. Fit the view.

6. Save Settings.

7. Exit MicroStation.
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The 12345DES_GenNote.dgn has been created in the project’s \Design\Drawings folder through the create 
project utility. This sheet file currently is linked to a generic notes doc file in the CDOT workspace. However, 
the sheet files should reference the project-specific notes file, 12345GemeralNote.dgn located in the 
\Design\Drawings\Reference Files folder. You must first update the references in the sheet file to point to 
the project notes, and then edit the project notes file to be project-specific. 

Note: This process is the same for any specialty group.

Chapter Objectives:

After completing this exercise you will know how to:

 Open a project notes sheet file.

 Update the Word document link to point to the 12345 project directory. 

 Edit the project-specific general notes Word file.

 Re-link the General Notes Word file to the Notes sheet file.

Lab 17.1 - Create Project General Notes Sheet

Updating Links

1. Start MicroStation and open the file 12345DES_GenNote##.dgn from the C:\Proj-
ects\12345\Design\Drawings folder.

This file was automatically generated by the create project utility program and contains 
links to a General Notes Word document in the generic project template folder. You will 
need to update these links to the General Notes Word document in the project folder.

2. Select Edit > Links.
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3. Highlight the first link in the list and select Change Source.

4. In the Change Source dialog box, set the Look in folder to 
C:\Projects\12345\Design\Drawings\Tabs and select the file 
12345DES_GenNote.doc.

5. Select Open to update the link.

6. Repeat this process for the second link.
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7. Close the Links dialog box.

8. Save Settings (File > Save Settings).

The General Notes sheet file is now linked to the GenNotes.doc file in the project-specific 
folder. You can now edit the Word file for your project-specific requirements.

Editing the Notes

1. Double click on the first notes link (left sheet).

This opens Microsoft Word and the GenNotes.doc file.

2. Read the first instructional paragraph (red text) and then delete it.

3. Delete the following text:

Prime Coat (MC-70) [XXXX] ...................................................@ .XX Gals./Sq. Yd.

Seal Coat (RC[XX]) Diluted Emulsified Asphalt [XXXX] .......@ XX Gals./Sq. Yd. 
(Diluted)

Cover Coat Material [XXXX].....................................................@ XX Lbs./Sq. Yd.

Tack Coat (AC[XX]....................................................................@ XX Lbs./Sq. Yd.

Asphalt Rejuvenating Agent [XXXX]........................................@ XX Gals./Sq. Yd.

4. Edit the following text to read as follows:

Tack Coat Diluted Emulsified Asphalt.......................................@ 0.1 Gals./Sq. Yd. 
(Diluted)
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Bituminous Pavement……….....................................................@ 110 Lbs./Sq. Yd./Inch

Aggregate Base Course (Class 6).................................. .............@ 133 Lbs/Cu Yd

5. At the bottom of the first column, add a blank line to place the paragraph beginning “The 
Contractor shall coordinate the shouldering…” at the top of the next column.

6. Look at the top of the next page and note that your edits have adjusted the text wrapping. 
The next page now starts with the note:

It is estimated that [XX] Mobile Pavement Marking Zone will be required on this project.

7. Review the text to make sure the edits are correct. If not, edit the text again until you’re 
satisfied.

8. In Word, select File > Exit and select Yes when prompted to save changes.

You are returned to the General Notes sheet in MicroStation.
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Review the changes in the sheet file

1. Zoom in on the notes on the first sheet and note your text edits have been updated in the 
DGN file.

2. Zoom in on the notes on the second sheet (right side) and notice that your edits have not 
been updated in the file.

Note: If you make edits that change the wrapping of text between pages in the Word 
document, you must re-link the file for the edits to update in the MicroStation 
DGN file.

Re-link the Word document

1. Use the Element Selection tool to select the Word document link on the second (right-
side) sheet.
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2. Select Delete.

3. Double-click on the Word document link on the first sheet to open the GenNotes.doc file.

4. Highlight all of the text on the second page and select Edit > Copy in Word.  

5. Do not close Word.

6. Switch to the MicroStation application.
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7. In MicroStation, select Edit > Paste Special and select the Linked Microsoft Office Word 
Document option and then select Paste.

8. In the Paste OLE box, set Paste As to Link and Method to By Corners.

9. Snap to the two ends of the top guideline as shown.
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10. Zoom in to review the notes and notice that the link has been updated to reflect your edits.

11. Switch over to the Word document and select File > Exit. If prompted to save the file, select 
Yes.

12. In MicroStation, Fit the view.

13. Save Settings.

14. Exit MicroStation.
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The M&S standard sheet is created by downloading the M&S Standards Plan List Index file from the CDOT 
web site. You can then update the reference in the M&S sheet file to point to this downloaded file.

Chapter Objectives:

After completing this exercise you will know how to:

 Download the M&S Index file from the CDOT web site.

 Update the M&S sheet file reference to the downloaded file.

 Use the Create Region command to update the M&S Index Sheet for the project.

Lab 18.1 - Create Project Standard Plans List Sheet

Open the Sheet File

1. Start MicroStation and open the 12345DES_StdPlanList.dgn file from the C:\Proj-
ects\12345\Design\Drawings folder.

The file opens and contains the border along with the M&S Standards Plan List reference. 
It also contains the web address to obtain the latest M&S Index file.
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2. Select References from the Primary toolbar.

Note that the M&S StandardPlansListIndex.dgn file is already referenced from the 
project’s \Design\Drawings folder. It was automatically placed here from the 
Create Project Directory utility. 

Note: If you need newer or different version of the M&S Standards, you can 
download it from the following web address: www.dot.state.co.us/
DesignSupport/.  Save the appropriate file to the project’s \Design\Drawings 
folder and then re-attach this reference.

Update the M&S Index

1. Turn off the DRAFT_INFO_No-Plot level to turn off the text.

Note: Since the text is on a “no plot” level, you don’t have to turn off the text. However, 
it just makes working in the file a bit easier.

2. Set the active level to DRAFT_WT-3.

3. Window in to the top of the sheet as shown.
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4. Select the Create Region command from the Groups toolbar and set the options as 
shown.

5. For the first plan in the list (M-100-1), <D> inside the block under the Plan Number 
column.

6. <D> to accept.

The block is filled-in using this tool.

7. Fill in other blocks as desired.
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Fill in the Border Information

1. From the CDOT Menu Explorer, select Drafting, then the Border RE category and select 
the Default Resident Engineer cell.

2. Apply.

3. Snap to the location shown to place the cell.
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4. Use the Edit Text command to edit the Project Number and Code as shown.

5. Use the Edit Text command to place your initials in the Designer and Detailer blocks.

6. Fit the view.

7. Save Settings (File > Save Settings).

8. Exit MicroStation.
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LAB 19 - Create a Title Sheet

In this lab, you’ll learn how to insert a Vicinity Map into the Project Title Sheet. 

Chapter Objectives:

After completing this exercise you will know how to:

 Open a project Title Sheet.

 Locate a vicinity map.

 Attach a vicinity map as a reference to the Title Sheet.

 Move and Clip the vicinity reference.

Lab 19.1 - Create Project Title Sheet

Open the Title Sheet file

1. Start MicroStation and open the file 12345DES_TitleSht.dgn for the C:\Proj-
ects\12345\Design\Drawings folder.

This file was automatically generated by the Create Project Utility program and contains a 
links to an Excel spreadsheet file in the generic project template folder. You will need to 
update these links to the 12345DES_TitleSht.xls file in the project folder.

Updating Links

1. Select Edit > Links.
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2. Highlight the first link in the list and select Change Source.

3. In the Change Source dialog box, set the Look in folder to 
C:\Projects\12345\Design\Drawings\Tabs and select the file 12345DES_TitleSht.xls.

4. Select Open to update the link.
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5. Repeat this process for the second link.

6. Close the Links dialog box.

7. Save Settings (File > Save Settings).

The Title sheet design file is now linked to the Excel spreadsheet file in the project-specific 
folder. You can now edit the Excel file for your project-specific requirements.

Edit the spreadsheet file

1. Double-click on the Tabulation of Length & Design Data link.

2. Excel starts and opens the 12345DES_TitleSht.xls file.
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3. In the Design Data portion of the file, make the following edits:

4. When finished, select File > Exit In Excel. When prompted to save changes to the file, 
select Yes.

5. Switch back to the MicroStation file and note that the edits are now updated in the DGN 
file.
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6. Window in on the Index of Sheets link on the right side of the sheet.

7. Using what you’ve learned, Edit the 12345DES_TitleSht.xls file and update the DGN file to 
read as shown below.

Note: When entering pages ranges (e.g. 3-4) be sure to put a quote mark (‘) at the 
beginning of text entry, otherwise Excel will interpret this as a date (i.e. March 4).
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Note: You can insert and delete rows as needed in Excel.

8. Edit the Border Text

9. Use the Edit Text command to make project specific edits to the border as shown.

10. Window in to the top center of the title sheet and edit the project numbers, highway 
number and county name as shown.
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11. Window in to the lower-right corner and make the project edits as shown.

12. Window in to the upper-right corner and make the project edits as shown.

13. Window around the bar scale and edit the text as shown.
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Place the RE cell

1. From the CDOT Menu, select Border RE from the Drafting group.

2. Place the Default RE cell in the location shown by snapping to the lower-left corner.

3. Fit the View.

4. Save Settings.

Lab 19.2 - Review the Vicinity Map

Vicinity maps can be referenced to the title sheet. These maps can be in the form of vector files 
(CADD elements) or raster files (images).
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The CDOT standard procedure is to use county maps that have been translated from GIS 
information, these maps can be found on the shared drive at: \\public\CADD County Maps\. The 
county of interest should be copied to your project’s …\Design\Drawings\Reference_Files 
folder and can be attached as a reference to the project’s Title Sheet file. 

5. Select File > Open and open Elbert.dgn from the 
C:\Projects\12345\Design\Drawings\Reference_Files folder.

The Elbert county map was translated from GIS and copied from the \\public\CADD County 
Maps\ shared drive. This file contains a Saved View to assist in attaching it as a reference 
file.

6. Select Utilities > Saved Views from the MicroStation pull-down menu
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7. <D> on the saved view by the name of plan and select Apply.

The MicroStation view updates to the limits of the saved view.  

8. Close the Saved Views dialog box.

9. Open the Level Display from the Primary toolbar. Note that all information resides on 
GIS_* levels.

10. Turn level displays on and off to verify the data is on the correct levels. Turn all levels on 
when finished.
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Attaching a vicinity map as a reference file

In the next series of steps, you will attach the vicinity file as a reference to the title sheet. 
Once attached, you can move, scale and clip the reference to fit the display limits in the 
sheet file.

1. Select File > Open and reopen the title sheet 12345DES_TitleSht.dgn from the project’s 
…\Design\Drawings folder.

2. Select References from the Primary toolbar.

3. In the References dialog, select Tools > Attach.

4. Set the directory to the project’s …\Design\Drawings\Reference_Files folder and select 
Elbert.dgn.

5. In the Attachment Settings box:

♦ Under Orientation, select plan (the saved view).

♦ Key in a Logical Name of Vicinity and a Description of GIS locator map for 
title sheet. 

♦ Key in a Scale of 1:5280 

Note: CDOT GIS maps are designed based on a 1-mile insertions scale (1 inch = 1 mile) 
for graphics. The linestyle and text scale factors are also based on this scale. 

6. Select OK.

The outline of the saved view reference is attached to your cursor. 

7. <D> anywhere underneath the plan sheet to attach the reference.

8. Select the MicroStation Fit command
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Move the reference file to align with the title sheet

1. In the References dialog box, select Tools > Move. 
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2. When prompted to enter a point to move from, <D> on section 13 on the vicinity reference.

3. <D> approximately in the center of the project location map block for the move to point.
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4. Continue to use the Move Reference command as needed to position the reference as 
shown. 

5. <R> when done.

Clip the vicinity map reference

1. In the Reference dialog, highlight the Vicinity reference

2. Select Tools > Clip Boundary from the Reference File dialog. 

3. In the Tool Settings box, set Method to Element.

4. MicroStation prompts ‘Select clipping element’

5. <D> on the shape representing the limits of the project location map.

6. <D> to accept.

7. Open Level Display and turn off the GIS_Sections-Text and GIS_Township-Text.
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8. Fit the view.

9. Save Settings.

10. Exit MicroStation.
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LAB 20 - Annotate the Intersection Plan/Profile 
Sheet

In this lab, you’ll annotate the plan/profile sheet with text, notes, and custom text strings using the CDOT 
Menu. 

Chapter Objectives:

After completing this exercise you will know how to:

 Set the active angle for placing text

 Place Text using the CDOT Menu

 Rotate text

 Place notes with leader lines and a line terminator

 Create and place custom text strings for utility lines using the CDOT Menu

Lab 20.1 - Open Project Plan/Profile Sheet

Start MicroStation

1. Start MicroStation and open 12345DES_PnP19.dgn from the C:\Proj‐
ects\12345\Design\Drawings folder.

Check Text Annotation Scale

1. Select Models from the Primary toolbar.
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2. In the Model box, select Edit Model Properties.

3. Note that the Text Annotation Scale is set to 1”=100’ (the default setting from the seed 
file).

Note: The Text Annotation Scale matches the border scale, which matches the scale for 
plotting – 1”=100’.

4. Cancel the Model Properties box.

5. Close the Models box.

Work with sheet levels and references

The plan limits cell placed along the mainline alignment in the Design model file appears in the 
sheet. This is on a No Plot level. However, if you don’t want to see it, you can turn it off.

1. Open Level Display and turn off the DRAFT_INFO_No_Plot level in the Design refer-
ence.
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2. In Level Display, turn off the Survey/Topo reference.

3. Select Settings > View Attributes, toggle on Level Overrides. 

This applies the Symbology Overrides set in the CDOT level libraries for “graying out” the 
existing contour levels.

Edit the bar scale text

1. Window in on the bar scale cell in the lower left portion of the plan view.

2. Use the Edit Text command to edit the text as shown for a 100 scale plot.
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Label the Intersection Alignments

Set the active angle for placing the county road text

1. On the CDOT Menu, select Settings.

2. Set the Active Angle to 0, Apply and then Close the box.

Set the text attributes using the CDOT Menu

1. On the CDOT Menu Explorer, select Drafting.  Set the category to Text and set the follow-
ing options:

♦ Filter: Standard (S)
♦ Justification:  Center Center
♦ Item: .07” 100% Standard

This sets the active level to DRAFT_Text‐3 and automatically selects the Place Text 
command.

2. In the Word Processor box, key in County Road 101.
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3. <D> to the left of the intersection as shown to label the road.

4. <R> out of the Place Text command when done.

Set the active angle for the main alignment text

1. Select Settings > Design File > Working Units.

2. Set the Options as shown for Conventional Angle Mode, Decimal Degrees.

3. Select the Measure Angle command from the Measure toolbar.
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4. <D> on the centerline of the side road.

5. <D> on the centerline of SH 86.

The angle reads out at 74.14 degrees.

6. From the CDOT Menu, select Settings and set the Active Angle to 74.14, Apply and 
then Close.

Place the SH 86 text at the active angle

1. On the CDOT Menu select Drafting > Text and select .07 again.

2. In the Word Processor box, key in SH 86.

3. <D> when shown to label the road.

4. <R> out of the Place Text command when done.

Lab 20.2 - Rotate the InRoads alignment text

1. Window in at the intersection as shown.

2. Select the Rotate command from the Manipulate toolbar.
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3. Set the Method to Active Angle, set the Angle to 180 and toggle On About 
Element Center.

4. <D> on the bearing text.

You can’t rotate the text because it’s in a reference.

Important! If you’re in the Design group and “own” the Design reference, you can 
“exchange” to that reference to make modifications. Otherwise, contact Design.

5. Select File > Save Settings.
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6. On the References dialog, select the Design reference and then select Tools > Exchange.

7. Select the Rotate command, <D> on the bearing text and then <D> to accept.

8. Select the File pull-down menu and open the sheet file from the list of last open files.

Lab 20.3 - Place Notes

1. Window in above the intersection to view the guardrail as shown.
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2. On the CDOT Menu Explorer, select Drafting > Text and select the .07” 100% Place 
Note item.

3.  Click inside the Word Processor box and key in Guardrail Type 3.

4. <D> on the guardrail as shown to define the start point of the note (note terminator).

5. Drag the cursor to the location shown and <D> to place the note leader.

6. IMPORTANT: With your cursor on the LEFT SIDE of the leader line, <R> to place the text.

Note: If your cursor is on the right side of the leader when you reset, your note will be 
placed on the right side.
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7. With the Place Note command still active, click in the Word Processor box and key in 
SH 86 STA 225+57.20.

8. On the Snap Mode toolbar select the Intersection Snap.

Note: You can also click in AccuDraw and press I on the keyboard.

9. AccuSnap to the intersection of the two centerlines as shown for the note terminator.

10. Drag your cursor out and <D> to place the leader line.

11. With our cursor on the RIGHT side of the leader, <R> to place the note.

Lab 20.4 - Attach and Annotate Utility Lines

Next, you’ll annotate proposed utility lines using the CDOT menu. However, the Utility model 
was not attached to plan sheet when it was created. Therefore, you must attach the Utility 
model after-the-fact in order to reference the utility lines for annotation.

Reference the proposed Utility model

1. Fit the view.

2. Open the References dialog box.
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3. Attach the 12345UTIL_Model.dgn file from project’s 
\Utilities\Drawings\Reference_Files folder. Be sure to attach Coincident-World 
at a 1:1 scale with No Nesting.

 The Utility model is reference, but needs clipping.
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4. On the References toolbar, select the Utility reference and then select Tools > Clip 
Boundary.

5.  <D> on the clip boundary block and then <D> to accept.
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Annotate the gas line

1. Window in on the plan sheet area shown.

2. From the CDOT Menu Explorer, select Group Display > Utilities and set the following 
options:

♦ Set Status to Proposed
♦ Set the Category to Gas
♦ Set Filters to All (or Text)

♦ Select the item <New Text String>

3.  In the Create Text String dialog box set the following from the drop down options:

♦ Set Size to 6”
♦ Set Material to PVC
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♦ For Owner, key in Xcel Energy

4.  Select OK.

5. When prompted to Identify Element, <D> on the proposed gas line.

6. <D> above the line to accept the text placement.

Note: Your custom text 6”, PVC, Xcel Energy is saved as an item in the Gas category for 
placement again.
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You can right-click on a custom text string and either edit or delete it.

Annotate the fiber optic line

1. Create a custom text string (6”, Qwest) for the fiber optic line and annotate as shown.

 

Note: Be sure to <D> near the bottom of the line to fit the annotation.

Lab 20.5 - Measure Graphics

Since you referenced your plan view graphics at a 1:1 scale, they are the actual size in the sheet 
file. Therefore, you can measure plan graphics in the sheet file and get the same results as 
measuring in the model file. Make sure that Locate is turned on for the reference before using 
the measuring tools on reference graphics.
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Measure Distance

Between points

1. Measure the OH Electrical Line with the CDOT custom add-on tool.

♦ From the CDOT Menu select CDOT Tools > Measure XY Distance
♦ In the XY Distance Dialog box, set Measurement Option to Between points
♦ AccuSnap on the two endpoints of the proposed Overhead electrical line as shown 

(snap to tie-in at power pole symbols – see arrows below)

♦ <R> when done

♦ Your results should match the dialog box

Along element

1. Measure the Gas Line with standard MicroStation tools.
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♦ Select the Measure Distance command from the Measure toolbar.

♦ Set the Method to Along Element
♦ AccuSnap on the start and end points of proposed 6” gas line as shown (see arrows).

♦ Record your results: ___________________________ft.

Note: Individual results will vary based on how the line was originally drawn.

2. Select the Measure Length command.
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♦  <D> on the gas line.

♦ Record your results: ___________________________ft.

Your results should be the same as in step 2. With this command, you only have to select 
the element with a data point to get its entire length.

3. Use Measure Length to measure the length of the OH Electrical line.

Your results should be the same as step 1 where you measure with the CDOT custom XY 
Distance tool.

Note: When measuring a straight line with this method, you also get the angle of the line.

Measure perpendicular

1. In the Design Model reference, turn Off the level 
DRAFT_LC-Center_WT-3.

This element (a blue dashed line) is a coincident to the alignment centerline. Since you will 
only be working with the alignment, turn this level off and leave the 
ALG_PROPOSED_Hor-Alignment turned on.

2. Turn Depth lock Off.

3. <T> on the side road horizontal alignment and note the Z value.

Horizontal Alignments, like this one, are typically placed at elevation 0. 

4. <T> on the red upper edge of oil line at the beginning of the alignment and note the Z value.

The edge of oil line is placed at the correct elevation.
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5. In the XY Distance dialog box, set the Option to Perpendicular from element.

6. <D> on the side road horizontal alignment.

MicroStation displays a horizontal tracking line.

7. AccuSnap on the end of the upper edge of oil line.

8. Review your results: 

Note that even though the two elements are at different elevations, the CDOT custom XY 
Distance tool provides both the Horizontal Distance of 18 feet along with the true 3D slope 
measurement (or Total Distance) of 6626.672 feet.
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LAB 21 - Annotate the Bridge General Layout 
Sheet

In this lab, you’ll annotate the bridge general layout sheet with text, notes and dimensions. 

Chapter Objectives:

After completing this exercise you will know how to:

 Set and change the Text Annotation Scale to match the drawing scale.

 Place dimensions using the following methods:

♦ Element

♦ Linear

♦ Angle between lines

♦ Bearing and Distance

 Edit dimension text.

 Place notes with curved leaders.

Lab 21.1 - Open Project Plan Sheet

1. Start MicroStation

2. Start MicroStation and open 12345BRDG_Plan01.dgn from the 
C:\Projects\12345\Bridge\Drawings folder.

Lab 21.2 - Place Text

Label the different part of the general layout sheet (plan, typical section, etc.)
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Set text attributes

1. On the CDOT Menu Explorer, select Drafting > Text and set the following options:

♦ Filter: Title (T)
♦ Justification:  Center Center
♦ Item: .30” 100% Title

Note: This sets the active level to DRAFT_Text-2 and automatically selects the Place 
Text command.

2. In the Word Processor box, key in Plan

3. Drag your cursor into the view.

4. <D> to place the text as shown.



Colorado Department of Transportation   Page 403

Labs for MicroStation XM LAB 21 - Annotate the Bridge General Layout Sheet

Note: The text is extremely large implying the text annotation scale is obviously wrong.

5. <R> out of the Place Text command.

Change the Text Annotation Scale

1. Select Models from the Primary toolbar.

2. In the Model box, select Edit Model Properties.

3. The Text Annotation Scale is set to 1:100 (the default setting from the seed file).

Note: This is a 40-scale drawing (the border was placed at a 40 scale around the 
graphics). Scaling the text 100 times results is text that is the wrong size.

4. Change the Text Annotation Scale to 1:40 and select OK.

5. In the Alert box, select Yes to propagate the new settings to existing text.
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6. The text “Plan” is automatically resized for a 40-scale drawing and will now measure 
correctly when plotted.

 

7. Close the Models box.

8. Select File > Save Settings to save the new settings.

9. Using the same text attribute settings, place the following text in the locations shown:

♦ Typical Section
♦ BT 54 Detail

10. Use the Move command to move the text to the desired location, if necessary.

Lab 21.3 - Dimension the Bridge Typical Section

Use the CDOT Menu to dimension the bridge typical section.
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Dimension the travel lanes and shoulder by element

1. Window around the typical section.

2. On the CDOT Menu Explorer, select Drafting and set the following options:

♦ Category: Dimensions
♦ Filter: x’-x”
♦ Item: Dimension  Element

Note: The Dimension Element command is automatically selected.

3. When prompted to select the element to dimension, <D> on the top pavement to the right 
of the centerline.

Note: This should select the 12 ft SmartLine segment which represents the travel lane, if 
not, <R> until you select the correct element.
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4. Move your cursor up to establish the length of the extension line and <D> to place the 
dimension.

5. Repeat for the 6 ft. right-shoulder segment. <D> on the segment near the extension line and 
then AccuSnap on the 12 ft. dimension’s terminator to place the dimension.

Note: The elements dimension actual size even though the bridge typical section was 
scaled up 4 times (40: 10 or 1:10 at a 40-scale). This is because Reference 
Scale is turned on in the Units tab of the dimension style. The units for 
dimensioning are, therefore, read from the model file instead of the sheet file. 
Reference Scale is on by default in all CDOT dimension styles.
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6. Repeat for the left side of the road. Be sure to AccuSnap on the adjacent dimension’s 
terminator to line up the dimensions.

Dimension the bridge rail curb using linear dimensions

1. On the CDOT Menu Explorer, change the Item to Dimension Linear Size

2. Following your prompts, AccuSnap on the end of the back of the rail for the start of the 
dimension.

3. Move your cursor up to the approximate location shown and <D> to define the length of 
the extension line.
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4. AccuSnap on the face of the curb as shown to define the end of the dimension.

Note: The dimension text is too large for the dimension when placed inside the extension 
lines. You can Modify the text to solve this problem.

5. Select the Modify tool from the Modify toolbar.

6. <D> on the 1’-6” curb dimension text.

7. Lock your cursor on AccuDraw X axis and move the text to the left as shown.

8. <R> when done.

9. Repeat the above steps and dimension the curb on the right side.
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Place additional linear dimensions

1. Using the Linear Dimension command, place additional dimensions for the width of the 
section as shown.

Measure the typical section

1. Select the Measure Distance command and set the method to Between Points.

2. AccuSnap on the left outside curb line.

3. AccuSnap on the right outside curb line.

4. Review your results.

The typical section measures 144 ft, which is 4 times the actual size since the detail was 
scaled up on the drawing. While dimension commands can read reference units (via the 
Reference Scale option in the dimension style), measuring command can not. You 
should only use Measuring command in sheet files where the graphics have been 
referenced 1:1 (like plan view graphics). If graphics have been scaled in the sheet, you 
must return to the model file for true measurements.

Edit dimensions 

Edit the dimension style

You can change the dimension style to show secondary units below the dimension line. While 
this is intended for dual dimensioning in metric, you can edit this text to add descriptions to 
your dimensions.

1. Select Element > Dimension Styles.

The Dimension Styles box opens. This is where all the CDOT standard dimension 
attributes are set. Typically, you will not need to change these settings for most dimensions.
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2. Select the CDOT 3 style and then select the Unit category and toggle on Show 
Secondary Units

Note: Do not select the save icon.

3. Close the Dimension Styles box.

Change dimensions

1. From the Dimension toolbar, select Change Dimension.

2. <D> on the 12 ft travel lane dimension and then <D> to accept.

The dimension is updated to show the secondary units.
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3. Repeat for the other dimensions as shown.

Change dimension text

1. Select the Edit Text command from the Text toolbar.

2. <D> on the 12 ft lane metric text.

Note: In the Text Editor, the dimension text appears as an asterisk (*) to denote that it is 
associative text.

3. Change the text to Lane.

4. <D> to accept.

The text is updated on the dimension.

5. Repeat for the other travel lane and the shoulders as shown.

Edit dimension text

1. Using the Edit Text command, <D> on the 36 ft text.
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2. In the Text Editor, click to the right of the asterisk to get a blinking cursor.

3. Space once and key in Curb to Curb.

4. <D> to accept.

Since you did not delete the asterisk, the text is still associated with the element. You just 
added text to the associated dimensions.

Dimension the Plan

Dimension the bearing of the centerline

1. On the CDOT menu, select Label Line.
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2. <D> on the SH 86 centerline.

Note: Both Bearing and Distance are placed. If you do not want one of the dimensions, 
you can drop the dimension, turn off the Graphic Group lock and then delete the 
dimension.

Measure the bridge area

1. Turn Depth lock on.

2. Turn AccuSnap off.

3. Select the Measure Area command from the Measure toolbar.

4. Set the Method to Points.

5. Snap to the four corners of the bridge as shown (see arrows) to dynamically draw a shape to 
measure.
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6. Reset <R> to close the shape to compute the area (do not loop back and snap on the first 
point).

Note: The Points method is the only method that gives you a planar area with Depth lock 
turned on.

Place a note with a curved leader

1. From the CDOT Menu, set the text options as shown.

2. Select the Place Note command.

3. In the Tool Settings box, set the Dimension Style to CDOT 3.

Note: The Place Note command uses a dimension style for the leader and terminator as 
well as a text style. The CDOT 3 style will place a curved leader without an in-line 
leader.
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4. Place the note as shown.

Note: Since this style does not use an in-line leader, you can place the text with a data 
point instead of a reset point on the side of the leader.
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Dimension the Girder Detail

1. Use the Element method to dimension the girder as shown.
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2. Use the Linear method to finish placing dimensions.
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3. Use the Modify command to move the dimension text as shown.

4. Fit the view.

5. Save Settings.

6. Exit MicroStation.
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In this lab, you’ll plot a single sheet to the classroom 11 x 17 printer.

Chapter Objectives:

After completing this exercise you will know how to:

 Prepare a single sheet for printing.

 Print an 11x17 sheet to a printer.

Lab 22.1 - Prepare the sheet for plotting

1. Start MicroStation and open 12345PDES_PnP9.dgn from the project’s 
…\Design\Drawings folder.

2. Fit the view.

3. Use the Edit Text command and edit the border text to add your initials as the Designer.

4. Select Place Fence and set the Fence Type to Block and Fence Mode to Inside.

5. Snap (<T>, then <D>) to the corners of the outer-most shape that goes all the way around 
the plan and profile sheet to place the fence. 
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Lab 22.2 - Print the sheet (classroom printer)

1. Select File > Print or choose the Print icon from the Standard toolbar.

2. From the Print dialog box, select File > Select Windows Printer and double-click on the 
Denver-HP1700 printer. .

3. Set the dialog as shown here. Be sure to set the Print Scale to 100.

4. Select the Print icon or File > Print.

The file is printed to the 11x17classroom plotter.

Note: For tips on printing raster references (e.g. aerial photos), see the workflow 
Printing Raster Images.

5. Do not exit. Keep MicroStation open for the final plotting exercise.

Lab 22.3 - Print the sheet (CDOT workflow)

1. Select File > Print or choose the Print icon from the Standard toolbar.

2. If prompted, select CDOT-DefaultPrinter_XM.pltcfg for the print driver, and then select 
OK.
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3. Set the dialog as shown here. Be sure to set the Print Scale to 100.

4. Select the Print icon or File > Print.

Note: For tips on printing raster references (e.g. aerial photos), see the workflow 
Printing Raster Images.

5. Do not exit. You’ll keep MicroStation open for the final plotting exercise.

Optional Exercise

1. Open the 12345BRDG_Plan01.dgn file from the project’s …\Bridge\Drawings 
folder.

2. Plot the sheet to the classroom printer. Be sure to set the Print Scale to 40. 

3. Do not exit. You’ll keep MicroStation open for the final plotting exercise.
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LAB 23 - Batch Printing to PDF

In this lab, you’ll use Batch Printing to print multiple files at one time. Instead of printing to a printer, you’ll 
print to PDF for the reproduction department (i.e. a plot set for a milestone submittals). 

Note: To batch print to a printer, see the workflow CDOT Batch Printing.

Chapter Objectives:

After completing this exercise you will know how to:

 Select files to batch print.

 Set and change batch process specifications.

 Create a batch process job file (*.job).

 Batch print to PDF files.

Lab 23.1 - Select Files to Batch Print

1. Select Batch Print in MicroStation from the file pull down menu.

Note: You can be in any MicroStation file when you run the Batch Print process.

2. In the Batch Print dialog box, select Edit > Add Files.

Note: Add Active File adds the design file that is open in MicroStation.

3. Navigate to the C:\Projects\12345\Design\Drawings folder.  Select the following 
files to add to the batch process (you can hold down the Ctrl or Shift key to select multiple 
files):

♦ 12345DES_GenNote.dgn
♦ 12345DES_PnP01.dgn – 12345DES_PnP19.dgn
♦ 12345DES_StdPlanList.dgn
♦ 12345DES_TitleSheet.dgn
♦ 12345DES_TyplSect01.dgn
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4. Select Add.

Note: If you want to add other sheets to the batch process, you can change folders, select 
the file(s) and select Add again.

5. When finished adding files, select Done.
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Lab 23.2 - Set Batch Process Specifications

1. The batch process default specifications are:

♦ Printer:  11x17 Printer
♦ Print Area:  SHEET_Plot-Boundary
♦ Layout:  Maximize
♦ Display:  As-Is Display

2. Select Specifications > Manage to change the default specifications.

3. Under Types, select Printer and PDF Printer

♦ Select Properties

♦ Select Driver and select CDOT-PDFDraftQuality_XM.pltcfg and select OK
♦ Toggle off Print document set to single file
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♦ Set the Directory to c:\projects\12345\Plot_Sets\

Note: To print all these sheets to a single PDF, the toggle for Print document set to 
single file must be ON

♦ Select OK
♦ Under Types, select Print Area and then select Properties.

Note: The printable area defaults to the outer boundary of the standard CDOT sheet 
border (the yellow shape on level SHEET_Plot-Boundary).

Just Master File is checked ON under Search Files.

If References is toggles ON and the level SHEET_Plot-Boundary is not found 
in the Master File as a cell, it will search for the level in the Reference files 
associated with the sheet file.  This might cause blank sheets to be generated.

4. Cancel the Properties box.
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5. Under Types, select Layout and then select Maximize.

6. Under Types, select Display

♦ Select As-Is Display
♦ Select Properties

Note: The As-Is Display Specification sets up the print properties for various 
elements. The As-Is setting reads MicroStation’s View Attributes setting for each 
design file. 

The Pen Table defaults to CDOT-PenTable.tbl, which is the table used for black-
and-white printing.

7. Cancel out of the Properties box.

8. Close the Batch Print Specification Manager box by selecting the X in the upper-right 
corner.
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Your changes are shown in the main Batch Print dialog box.
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LAB 23 - Save your Specifications to a Job file 
(*.job)

1. From the Batch Print dialog box, select File>Save As…

2. Navigate to the project’s …Plot_Sets folder.

Note: You should select one of the subfolders (FIR, FOR, etc.) for the appropriate plot 
set. For training purposes, you’ll plot to the upper level Plot Sets folder.

3. In the Files field, key in 12345 and select OK.

The job file should be saved to the project in the appropriate folder under the Plot_Sets. 
The file is automatically assigned a .job extension. If you want to process this job again, 
select File > Open from the Batch Print dialog box and choose the 12345.job file.

Lab 23.1 - Create the Batch Prints

1. Select the Print icon to open the Print Batch dialog box.
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2. In the Print Batch dialog box, set Print Range to All to print all the files selected

Note: The option Selection would print only the files that you highlight in the list.

3. Select OK to start the batch process.

The process will take a few minutes to complete. If errors are encountered, open the error 
log batchplt.log in the C:\Projects\12345\Plot_Sets\ folder for more information.

Lab 23.2 - Review the PDF files

1. In Windows, open My Computer.

2. Navigate to the C:\Projects\12345\Plot_Sets\ folder.
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Note: The folder contains the all the individual pdf file sheets plus the 12345.job file 
and batch log file.

3. Double-click on one of the pdf files to open. 

4. Continue opening sheets as desired.

5. Close My Computer.

6. Return to MicroStation and Exit.
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